aboutsummaryrefslogtreecommitdiff
path: root/libs/libseccomp/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2020-01-17 00:33:31 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2020-01-17 00:55:42 +0200
commitc01462dcba15ad4343c6e709f5244bc25f3a01ba (patch)
treeffa98891bb7f6839ed79934e0f8a9f96a7cc25f7 /libs/libseccomp/Makefile
parentc13184366330a72ffd909b605e5a3fb874f23077 (diff)
libseccomp: install missing header file
As of version 2.4.2, libseccomp ships a new header file seccomp-syscalls.h. Install it in InstallDev. Fixes: 71b663b335da ("libseccomp: update to version 2.4.2") Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libseccomp/Makefile')
-rw-r--r--libs/libseccomp/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/libseccomp/Makefile b/libs/libseccomp/Makefile
index a39250eec..78fba9693 100644
--- a/libs/libseccomp/Makefile
+++ b/libs/libseccomp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libseccomp
PKG_VERSION:=2.4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -67,7 +67,7 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
$(CP) \
- $(PKG_INSTALL_DIR)/usr/include/seccomp.h \
+ $(PKG_INSTALL_DIR)/usr/include/seccomp*.h \
$(1)/usr/include/
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libseccomp.{a,so*} \