aboutsummaryrefslogtreecommitdiff
path: root/libs/libseccomp/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-09-19 02:12:02 -0700
committerRosen Penev <rosenp@gmail.com>2021-09-26 22:35:50 -0700
commit17d2f61c7b2ba6f748b072f2f1a8ac2933bde466 (patch)
tree034624d221893bc745aebf79f55d7160011a23fe /libs/libseccomp/Makefile
parent31dbc888cc4ba3e04894ffb137d0e3d9bac6f244 (diff)
libseccomp: update to 2.5.2
Use AUTORELEASE for simplicity. Add libtool patch to fix compilation under some platforms. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libseccomp/Makefile')
-rw-r--r--libs/libseccomp/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/libs/libseccomp/Makefile b/libs/libseccomp/Makefile
index e82ec751b..0ab08a101 100644
--- a/libs/libseccomp/Makefile
+++ b/libs/libseccomp/Makefile
@@ -8,19 +8,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libseccomp
-PKG_VERSION:=2.5.1
-PKG_RELEASE:=1
+PKG_VERSION:=2.5.2
+PKG_RELEASE:=$(AUTORELEASE)
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/seccomp/libseccomp/releases/download/v$(PKG_VERSION)/
-PKG_HASH:=ee307e383c77aa7995abc5ada544d51c9723ae399768a97667d4cdb3c3a30d55
+PKG_HASH:=17a652dfb491d96be893960e9b791914936ee16c13b777a3caf562fe48cb87df
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:libseccomp_project:libseccomp
+PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=gperf/host