aboutsummaryrefslogtreecommitdiff
path: root/libs/libsearpc
diff options
context:
space:
mode:
authorGergely Kiss <mail.gery@gmail.com>2016-04-30 10:37:30 +0200
committerEtienne CHAMPETIER <champetier.etienne@gmail.com>2016-08-24 20:35:33 +0000
commit437621931a1561ae23604c619fde40f78d750c3c (patch)
tree59c792f612d9fb2f199d18e2397e3487248dbb1d /libs/libsearpc
parent39e937fae7608da2e260505e312d8d5f5ed7a225 (diff)
seafile: import version 5.1.1 and its dependencies
Signed-off-by: Gergely Kiss <mail.gery@gmail.com>
Diffstat (limited to 'libs/libsearpc')
-rw-r--r--libs/libsearpc/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/libs/libsearpc/Makefile b/libs/libsearpc/Makefile
index 15c0e8ba3..2e99b2ea7 100644
--- a/libs/libsearpc/Makefile
+++ b/libs/libsearpc/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2014 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libsearpc
-PKG_VERSION:=3.1.7
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
+PKG_VERSION:=5.1.1
+PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
PKG_LICENSE:=GPL-3.0
PKG_SOURCE_PROTO:=git
@@ -22,6 +22,7 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
+$(call include_mk, python-package.mk)
define Package/libsearpc
SECTION:=libs
@@ -43,21 +44,6 @@ CONFIGURE_ARGS += --enable-compile-demo=no \
TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib -liconv
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Configure
-endef
-
-define Host/Compile
-endef
-
-define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR)/host/bin
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/lib/searpc-codegen.py $(STAGING_DIR)/host/bin/
-endef
-
-$(eval $(call HostBuild))
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{bin,include}
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
@@ -69,9 +55,10 @@ endef
define Package/libsearpc/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_DIR) $(1)/usr/lib/python2.7/site-packages
+ $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsearpc.so* $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/python2.7/site-packages/pysearpc $(1)/usr/lib/python2.7/site-packages/
+ $(CP) $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/pysearpc $(1)$(PYTHON_PKG_DIR)
+ find $(1) -name "*\.pyc" -o -name "*\.pyo" | xargs rm -f
endef
$(eval $(call BuildPackage,libsearpc))