aboutsummaryrefslogtreecommitdiff
path: root/libs/libsamplerate
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-07-31 13:04:53 -0400
committerTed Hess <thess@kitschensync.net>2014-07-31 13:04:53 -0400
commit6f937821fc2ccebc92ef299069ca20c5fecd9c8c (patch)
tree6141a45947614371ad045ff5d30d1afb52bcde56 /libs/libsamplerate
parent476041c026b8d012aa2bfe2ded27b6e1310437c6 (diff)
libsamplerate: import from oldpackages, upgrade to 0.1.8, fix build, add myself as pkg maintainer
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/libsamplerate')
-rw-r--r--libs/libsamplerate/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/libs/libsamplerate/Makefile b/libs/libsamplerate/Makefile
new file mode 100644
index 000000000..1a6af6790
--- /dev/null
+++ b/libs/libsamplerate/Makefile
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2007-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libsamplerate
+PKG_VERSION:=0.1.8
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.mega-nerd.com/SRC/
+PKG_MD5SUM:=1c7fb25191b4e6e3628d198a66a84f47
+
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILE:=COPYING
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libsamplerate
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libsndfile
+ TITLE:=Sample Rate Converter
+ URL:=http://www.mega-nerd.com/SRC/index.html
+endef
+
+define Package/libsamplerate/description
+ Secret Rabbit Code (aka libsamplerate) is a Sample Rate
+ Converter for audio.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --disable-fftw \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libsamplerate/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsamplerate.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libsamplerate))