aboutsummaryrefslogtreecommitdiff
path: root/libs/libpsl
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-12 18:50:11 -0700
committerRosen Penev <rosenp@gmail.com>2020-09-12 18:51:01 -0700
commita85f2e141a3b872fe7dabb0fe78c261d894eb73d (patch)
tree8fbbd3af844ce8ba002650da64f1f5cc66aa7a1f /libs/libpsl
parent9ef725a5ce81920d9073da2412011131c0e4f130 (diff)
libpsl: fix compilation with debian setuptools
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libpsl')
-rw-r--r--libs/libpsl/Makefile2
-rw-r--r--libs/libpsl/patches/010-python.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/libpsl/Makefile b/libs/libpsl/Makefile
index 176e5cf91..ffd6758e9 100644
--- a/libs/libpsl/Makefile
+++ b/libs/libpsl/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libpsl
PKG_VERSION:=0.21.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/rockdaboot/libpsl/releases/download/$(PKG_VERSION)
diff --git a/libs/libpsl/patches/010-python.patch b/libs/libpsl/patches/010-python.patch
new file mode 100644
index 000000000..d601fd69d
--- /dev/null
+++ b/libs/libpsl/patches/010-python.patch
@@ -0,0 +1,11 @@
+--- a/meson.build
++++ b/meson.build
+@@ -131,7 +131,7 @@ if psl_test_file == ''
+ psl_test_file = join_paths(meson.current_source_dir(), 'list', 'tests', 'tests.txt')
+ endif
+
+-python = import('python').find_installation()
++python = 'python3'
+ pkgconfig = import('pkgconfig')
+
+ if cc.get_id() == 'msvc'