aboutsummaryrefslogtreecommitdiff
path: root/libs/libpsl
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2023-05-19 08:26:18 -0500
committerTianling Shen <cnsztl@gmail.com>2023-05-20 13:13:27 +0800
commit71fb98ea4529ccb9749f1fca6670b1966978f9ed (patch)
treeb259929afc85697045dc622f84c11326967e159d /libs/libpsl
parentd6f6a393df7bb1e14e7894074b84f19bd7520a40 (diff)
libpsl: update to 0.21.2
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs/libpsl')
-rw-r--r--libs/libpsl/Makefile10
-rw-r--r--libs/libpsl/patches/010-python.patch11
-rw-r--r--libs/libpsl/patches/020-iconv.patch29
3 files changed, 3 insertions, 47 deletions
diff --git a/libs/libpsl/Makefile b/libs/libpsl/Makefile
index 92d2249c1..ea7bb8221 100644
--- a/libs/libpsl/Makefile
+++ b/libs/libpsl/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libpsl
-PKG_VERSION:=0.21.1
-PKG_RELEASE:=3
+PKG_VERSION:=0.21.2
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/rockdaboot/libpsl/releases/download/$(PKG_VERSION)
-PKG_HASH:=ac6ce1e1fbd4d0254c4ddb9d37f1fa99dec83619c1253328155206b896210d4c
+PKG_HASH:=e35991b6e17001afa2c0ca3b10c357650602b92596209b7492802f3768a6285f
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_LICENSE:=MIT
@@ -34,10 +34,6 @@ define Package/libpsl/description
C library to handle the Public Suffix List
endef
-MESON_ARGS += \
- -Druntime=libidn2 \
- -Dbuiltin=libidn2
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/include/libpsl.h $(1)/usr/include/
diff --git a/libs/libpsl/patches/010-python.patch b/libs/libpsl/patches/010-python.patch
deleted file mode 100644
index d601fd69d..000000000
--- a/libs/libpsl/patches/010-python.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -131,7 +131,7 @@ if psl_test_file == ''
- psl_test_file = join_paths(meson.current_source_dir(), 'list', 'tests', 'tests.txt')
- endif
-
--python = import('python').find_installation()
-+python = 'python3'
- pkgconfig = import('pkgconfig')
-
- if cc.get_id() == 'msvc'
diff --git a/libs/libpsl/patches/020-iconv.patch b/libs/libpsl/patches/020-iconv.patch
deleted file mode 100644
index 63c9c752f..000000000
--- a/libs/libpsl/patches/020-iconv.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -20,6 +20,7 @@ libicu_dep = notfound
- libidn_dep = notfound
- libunistring = notfound
- networking_deps = notfound
-+libiconv_dep = notfound
-
- # FIXME: Cleanup this when Meson gets 'feature-combo':
- # https://github.com/mesonbuild/meson/issues/4566
-@@ -86,6 +87,7 @@ endif
- if libidn2_dep.found() or libidn_dep.found()
- # Check for libunistring, we need it for psl_str_to_utf8lower()
- libunistring = cc.find_library('unistring')
-+ libiconv_dep = dependency('iconv')
- endif
-
- if host_machine.system() == 'windows'
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -19,7 +19,7 @@ cargs = [
- libpsl = library('psl', sources, suffixes_dafsa_h,
- include_directories : [configinc, includedir],
- c_args : cargs,
-- dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps],
-+ dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps, libiconv_dep],
- version: lt_version,
- install: true,
- )