aboutsummaryrefslogtreecommitdiff
path: root/libs/libplist/Makefile
diff options
context:
space:
mode:
authorEspen Jürgensen <espenjurgensen+openwrt@gmail.com>2020-06-26 23:55:39 +0200
committerEspen Jürgensen <espenjurgensen+openwrt@gmail.com>2020-06-27 09:02:39 +0200
commitca1bbd228f15208e53455465dfd3487e9b7a5d4d (patch)
tree02e374d974fc7240a9ea87647ae28ee4f73d10d4 /libs/libplist/Makefile
parent65af93279d217aef635bda80cd16dcc17c725ec6 (diff)
libplist: add missing pkgconfig files in libplist 2.2
Closes #12571. Same fix as Debian, see: https://github.com/libimobiledevice/libplist/commit/137716df3f197a7184c1fba88fcb30480dafd6e0#commitcomment-40099153 Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
Diffstat (limited to 'libs/libplist/Makefile')
-rw-r--r--libs/libplist/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/libs/libplist/Makefile b/libs/libplist/Makefile
index 5707fdb71..73595a77e 100644
--- a/libs/libplist/Makefile
+++ b/libs/libplist/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libplist
PKG_VERSION:=2.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.libimobiledevice.org/downloads
@@ -92,7 +92,10 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist-2.0*.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libplist*.pc $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libplist++-2.0.pc $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libplist-2.0.pc $(1)/usr/lib/pkgconfig/
+ $(LN) libplist++-2.0.pc $(1)/usr/lib/pkgconfig/libplist++.pc
+ $(LN) libplist-2.0.pc $(1)/usr/lib/pkgconfig/libplist.pc
endef
define Package/libplist/install