aboutsummaryrefslogtreecommitdiff
path: root/libs/libpfring
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2023-04-21 16:32:27 +0000
committerPaul Spooren <mail@aparcar.org>2023-04-21 22:46:58 +0200
commit0c10c224be81f9221dabfab449855ab6718d2a0c (patch)
treec7e9f983c60cbf9ae17bce5f64dc72963c67a6d3 /libs/libpfring
parent018fcf3ccd3c65c92f7c9467ab35f345fbd2c1ae (diff)
treewide: remove AUTORELEASE
Automatically compute and substitute current values for all $(AUTORELEASE) instances as this feature is deprecated and shouldn't be used. The following temporary change was made to the core: diff --git a/rules.mk b/rules.mk index 57d7995d4fa8..f16367de87a8 100644 --- a/rules.mk +++ b/rules.mk @@ -429,7 +429,7 @@ endef abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1)))) COMMITCOUNT = $(if $(DUMP),0,$(call commitcount)) -AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1)) +AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile)) all: FORCE: ; And this command used to fix affected packages: for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \ sed 's^.*/\([^/]*\)/Makefile^\1^';); do make package/$i/download done Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'libs/libpfring')
-rw-r--r--libs/libpfring/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/libs/libpfring/Makefile b/libs/libpfring/Makefile
index 6123c87b3..f02e3ed48 100644
--- a/libs/libpfring/Makefile
+++ b/libs/libpfring/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=libpfring
PKG_VERSION:=8.0.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ntop/PF_RING/tar.gz/$(PKG_VERSION)?