aboutsummaryrefslogtreecommitdiff
path: root/libs/libpfring/Makefile
diff options
context:
space:
mode:
authorBangLang Huang <banglang.huang@foxmail.com>2017-12-23 20:32:38 +0800
committerStijn Tintel <stijn@linux-ipv6.be>2018-10-02 20:43:48 +0300
commitbc01c8eae6ef0d87b1a0e6ac676605cacbd52014 (patch)
treee9537280d1efcd3b64265a9164d25ed53f946e08 /libs/libpfring/Makefile
parentc4ab18d58e63130c7a88f881a8ba96628b9f8598 (diff)
libpfring: add new package
PF_RING is a high speed packet capture library that turns a commodity PC into an efficient and cheap network measurement box suitable for both packet and active traffic analysis and manipulation. Moreover, PF_RING opens totally new markets as it enables the creation of efficient application such as traffic balancers or packet filters in a matter of lines of codes. github : https://github.com/ntop/pf_ring official : https://www.ntop.org Signed-off-by: BangLang Huang <banglang.huang@foxmail.com> Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> [rename kmod-pfring to kmod-pf-ring]
Diffstat (limited to 'libs/libpfring/Makefile')
-rw-r--r--libs/libpfring/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/libs/libpfring/Makefile b/libs/libpfring/Makefile
new file mode 100644
index 000000000..3cc05658c
--- /dev/null
+++ b/libs/libpfring/Makefile
@@ -0,0 +1,69 @@
+#
+# Copyright (C) 2017 Banglang Huang
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libpfring
+PKG_VERSION:=7.2.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Banglang Huang <banglang.huang@foxmail.com>
+
+PKG_LICENSE:=LGPL-2.1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/ntop/PF_RING/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=5d349ac37a6ece5966bf606a6f131d628b98d88654c2f502d3c4b8bbf6ef9796
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/PF_RING-$(PKG_VERSION)
+
+PKG_INSTALL:=1
+PKG_FIXUP:=patch-libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+CONFIGURE_PATH:=userland
+MAKE_PATH:=userland/lib
+
+define Package/libpfring
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Library for PR_RING (package process framework)
+ URL:=https://github.com/ntop/pf_ring
+ DEPENDS:=+kmod-pfring +libpcap +libpthread
+endef
+
+define Package/libpfring/description
+ PF_RING is a high speed packet capture library that turns a commodity PC into an efficient and cheap
+ network measurement box suitable for both packet and active traffic analysis and manipulation.
+ Moreover, PF_RING opens totally new markets as it enables the creation of efficient application such as
+ traffic balancers or packet filters in a matter of lines of codes.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/* \
+ $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libpfring.so* \
+ $(1)/usr/lib/
+endef
+
+CONFIGURE_VARS += \
+ MACHINE="$(ARCH)"
+
+define Package/libpfring/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libpfring.so* \
+ $(1)/usr/lib/
+ $(LN) libpfring.so $(1)/usr/lib/libpfring.so.1
+endef
+
+$(eval $(call BuildPackage,libpfring))