aboutsummaryrefslogtreecommitdiff
path: root/libs/libpam/patches
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2015-06-18 17:57:03 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2015-06-18 18:07:01 +0800
commitd5697f6a9589912c5caa1c432fd4b37ae63c1639 (patch)
tree0eb95a246464eca65c0f29e31ec21efce5e19919 /libs/libpam/patches
parent530772b9d045b507aaaf04547d5bb8c30f6aaeec (diff)
libpam: fix build.
- Update PKG_MD5SUM. - Update PKG_RELEASE. - Update patch 0001- to always use /lib directory. - Refresh other patches. Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'libs/libpam/patches')
-rw-r--r--libs/libpam/patches/0001-build-always-use-lib-instead-of-lib64.patch36
-rw-r--r--libs/libpam/patches/0001-build-use-host_cpu-for-lib64-directory-handling.patch28
-rw-r--r--libs/libpam/patches/0002-build-ignore-pam_rhosts-if-neither-ruserok-nor-ruser.patch6
-rw-r--r--libs/libpam/patches/0003-build-ignore-pam_lastlog-when-logwtmp-is-not-availab.patch6
-rw-r--r--libs/libpam/patches/0004-build-fix-build-when-crypt-is-not-part-of-crypt_libs.patch6
-rw-r--r--libs/libpam/patches/0005-build-fix-doc-build.patch2
-rw-r--r--libs/libpam/patches/0006-pam_unix-fix-compilation-in-case-rpc-rpc.h-is-missin.patch2
-rw-r--r--libs/libpam/patches/0007-Check-if-innetgr-is-available-at-compile-time.patch2
8 files changed, 48 insertions, 40 deletions
diff --git a/libs/libpam/patches/0001-build-always-use-lib-instead-of-lib64.patch b/libs/libpam/patches/0001-build-always-use-lib-instead-of-lib64.patch
new file mode 100644
index 000000000..25d9a4ab7
--- /dev/null
+++ b/libs/libpam/patches/0001-build-always-use-lib-instead-of-lib64.patch
@@ -0,0 +1,36 @@
+From 1948dd03d69c1a50e92d7e8868b7d6eabd4873c1 Mon Sep 17 00:00:00 2001
+From: Yousong Zhou <yszhou4tech@gmail.com>
+Date: Wed, 17 Jun 2015 16:11:31 +0800
+Subject: [PATCH 1/7] build: always use /lib instead of /lib64.
+
+* configure.ac: OpenWrt does not use /lib64.
+
+Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
+---
+ configure.ac | 10 +---------
+ 1 file changed, 1 insertion(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fd0e310..306b6e2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,15 +25,7 @@ dnl If we use /usr as prefix, use /etc for config files
+ then
+ sysconfdir="/etc"
+ fi
+- if test ${libdir} = '${exec_prefix}/lib'
+- then
+- case "`uname -m`" in
+- x86_64|ppc64|s390x|sparc64)
+- libdir="/lib64" ;;
+- *)
+- libdir="/lib" ;;
+- esac
+- fi
++ libdir="/lib"
+ if test ${sbindir} = '${exec_prefix}/sbin'
+ then
+ sbindir="/sbin"
+--
+1.7.10.4
+
diff --git a/libs/libpam/patches/0001-build-use-host_cpu-for-lib64-directory-handling.patch b/libs/libpam/patches/0001-build-use-host_cpu-for-lib64-directory-handling.patch
deleted file mode 100644
index 038b21422..000000000
--- a/libs/libpam/patches/0001-build-use-host_cpu-for-lib64-directory-handling.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ee916fd0ec70eb37a97da29f6ec0c26bef7cf6f2 Mon Sep 17 00:00:00 2001
-From: Yousong Zhou <yszhou4tech@gmail.com>
-Date: Wed, 17 Jun 2015 16:11:31 +0800
-Subject: [PATCH 1/7] build: use $host_cpu for lib64 directory handling.
-
-* configure.ac: use $host_cpu for lib64 directory handling.
-
-Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index fd0e310..1bc2591 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -27,7 +27,7 @@ dnl If we use /usr as prefix, use /etc for config files
- fi
- if test ${libdir} = '${exec_prefix}/lib'
- then
-- case "`uname -m`" in
-+ case "$host_cpu" in
- x86_64|ppc64|s390x|sparc64)
- libdir="/lib64" ;;
- *)
---
-1.7.10.4
-
diff --git a/libs/libpam/patches/0002-build-ignore-pam_rhosts-if-neither-ruserok-nor-ruser.patch b/libs/libpam/patches/0002-build-ignore-pam_rhosts-if-neither-ruserok-nor-ruser.patch
index c3eda4155..abafcbb24 100644
--- a/libs/libpam/patches/0002-build-ignore-pam_rhosts-if-neither-ruserok-nor-ruser.patch
+++ b/libs/libpam/patches/0002-build-ignore-pam_rhosts-if-neither-ruserok-nor-ruser.patch
@@ -1,4 +1,4 @@
-From e985c1ef2c739a597b2d7a2efc3c310c02e40c1f Mon Sep 17 00:00:00 2001
+From 1a2e6c979118dce5e79604e88c008c7879d1e4e6 Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Wed, 17 Jun 2015 18:19:23 +0800
Subject: [PATCH 2/7] build: ignore pam_rhosts if neither ruserok nor
@@ -16,10 +16,10 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
3 files changed, 13 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 1bc2591..3c4d8bb 100644
+index 306b6e2..084071a 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -542,7 +542,10 @@ AC_CHECK_FUNCS(fseeko getdomainname gethostname gettimeofday lckpwdf mkdir selec
+@@ -534,7 +534,10 @@ AC_CHECK_FUNCS(fseeko getdomainname gethostname gettimeofday lckpwdf mkdir selec
AC_CHECK_FUNCS(strcspn strdup strspn strstr strtol uname)
AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r)
AC_CHECK_FUNCS(getgrouplist getline getdelim)
diff --git a/libs/libpam/patches/0003-build-ignore-pam_lastlog-when-logwtmp-is-not-availab.patch b/libs/libpam/patches/0003-build-ignore-pam_lastlog-when-logwtmp-is-not-availab.patch
index ddcb66228..2f3f19cb3 100644
--- a/libs/libpam/patches/0003-build-ignore-pam_lastlog-when-logwtmp-is-not-availab.patch
+++ b/libs/libpam/patches/0003-build-ignore-pam_lastlog-when-logwtmp-is-not-availab.patch
@@ -1,4 +1,4 @@
-From 173164996ca7daf3fa705f2a0bb2991b0d5d2083 Mon Sep 17 00:00:00 2001
+From bac1ee3033cf22e31730fe3e77ca82bd5ebba692 Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Wed, 17 Jun 2015 21:18:05 +0800
Subject: [PATCH 3/7] build: ignore pam_lastlog when logwtmp is not available.
@@ -13,10 +13,10 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
2 files changed, 8 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 3c4d8bb..8de6edf 100644
+index 084071a..ca4bf5b 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -544,8 +544,10 @@ AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r
+@@ -536,8 +536,10 @@ AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r
AC_CHECK_FUNCS(getgrouplist getline getdelim)
AC_CHECK_FUNCS(inet_ntop inet_pton innetgr)
AC_CHECK_FUNCS([ruserok_af ruserok], [break])
diff --git a/libs/libpam/patches/0004-build-fix-build-when-crypt-is-not-part-of-crypt_libs.patch b/libs/libpam/patches/0004-build-fix-build-when-crypt-is-not-part-of-crypt_libs.patch
index ee319d11b..04e617326 100644
--- a/libs/libpam/patches/0004-build-fix-build-when-crypt-is-not-part-of-crypt_libs.patch
+++ b/libs/libpam/patches/0004-build-fix-build-when-crypt-is-not-part-of-crypt_libs.patch
@@ -1,4 +1,4 @@
-From 20e5efe4b2a8471bc52e480e53cff68a4de19c56 Mon Sep 17 00:00:00 2001
+From a35daea1b8be768d1b0be6eae157fbf3e5380f92 Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Wed, 17 Jun 2015 18:22:31 +0800
Subject: [PATCH 4/7] build: fix build when crypt() is not part of crypt_libs.
@@ -11,10 +11,10 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index 8de6edf..c15441b 100644
+index ca4bf5b..6553c78 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -416,7 +416,7 @@ AS_IF([test "x$ac_cv_header_xcrypt_h" = "xyes"],
+@@ -408,7 +408,7 @@ AS_IF([test "x$ac_cv_header_xcrypt_h" = "xyes"],
[crypt_libs="crypt"])
BACKUP_LIBS=$LIBS
diff --git a/libs/libpam/patches/0005-build-fix-doc-build.patch b/libs/libpam/patches/0005-build-fix-doc-build.patch
index 132012439..cd9b0a802 100644
--- a/libs/libpam/patches/0005-build-fix-doc-build.patch
+++ b/libs/libpam/patches/0005-build-fix-doc-build.patch
@@ -1,4 +1,4 @@
-From df7abf333d19aefd166f613b696345732ae4c9c8 Mon Sep 17 00:00:00 2001
+From 1563e57ea8ab9d123f765129a6840929ef58ff7a Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Wed, 17 Jun 2015 20:38:41 +0800
Subject: [PATCH 5/7] build: fix doc build.
diff --git a/libs/libpam/patches/0006-pam_unix-fix-compilation-in-case-rpc-rpc.h-is-missin.patch b/libs/libpam/patches/0006-pam_unix-fix-compilation-in-case-rpc-rpc.h-is-missin.patch
index bfdfd8b4c..014684f29 100644
--- a/libs/libpam/patches/0006-pam_unix-fix-compilation-in-case-rpc-rpc.h-is-missin.patch
+++ b/libs/libpam/patches/0006-pam_unix-fix-compilation-in-case-rpc-rpc.h-is-missin.patch
@@ -1,4 +1,4 @@
-From 596797ab7f46fb4d0338e75db7c0d1019cd4df87 Mon Sep 17 00:00:00 2001
+From 2e3ed4c6fb09f84fede589047d37d11783202d34 Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Wed, 17 Jun 2015 18:16:18 +0800
Subject: [PATCH 6/7] pam_unix: fix compilation in case rpc/rpc.h is missing.
diff --git a/libs/libpam/patches/0007-Check-if-innetgr-is-available-at-compile-time.patch b/libs/libpam/patches/0007-Check-if-innetgr-is-available-at-compile-time.patch
index 7108b6bed..f79b01aeb 100644
--- a/libs/libpam/patches/0007-Check-if-innetgr-is-available-at-compile-time.patch
+++ b/libs/libpam/patches/0007-Check-if-innetgr-is-available-at-compile-time.patch
@@ -1,4 +1,4 @@
-From 9e2fa22891a87592c1a04801623fea5be40cb581 Mon Sep 17 00:00:00 2001
+From c681bd104627139eac2f40fe303e1f67676233e8 Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Wed, 17 Jun 2015 15:33:43 +0800
Subject: [PATCH 7/7] Check if innetgr is available at compile time.