aboutsummaryrefslogtreecommitdiff
path: root/libs/libp11/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-01-03 12:05:55 -0800
committerRosen Penev <rosenp@gmail.com>2019-01-03 12:05:55 -0800
commit12acb5b77a961d424e0d2ff4d908fb72b28d2e7e (patch)
treedf858a07d0c26bba2f2db6002a8a5458ea38bd1f /libs/libp11/Makefile
parent187f61aab9c7cf4cb5fcbd542002a655c738b09a (diff)
libp11: Mandate ENGINE support
libp11 uses OpenSSL's ENGINE quite extensively with seemingly no simple way to disable it. Add it as a dependency. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libp11/Makefile')
-rw-r--r--libs/libp11/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/libp11/Makefile b/libs/libp11/Makefile
index 559a229c9..8d85aca95 100644
--- a/libs/libp11/Makefile
+++ b/libs/libp11/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libp11
PKG_VERSION:=0.4.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://github.com/OpenSC/libp11/releases/download/$(PKG_NAME)-$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -30,7 +30,7 @@ define Package/libp11
CATEGORY:=Libraries
TITLE:=PKCS#11 wrapper library
URL:=https://www.opensc-project.org/opensc/wiki/libp11
- DEPENDS:=+libopenssl
+ DEPENDS:=+libopenssl @OPENSSL_ENGINE
CONFLICTS:=engine_pkcs11
endef