aboutsummaryrefslogtreecommitdiff
path: root/libs/libowfat
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2014-06-13 17:03:40 +0200
committerDaniel Golle <daniel@makrotopia.org>2014-06-13 17:04:53 +0200
commit4a5b047c084026181f799a66713234fed4446837 (patch)
treebcbf7cf2e8514c98e12c2b7b724e9cbc1d574e4b /libs/libowfat
parentbea53b612f8dda6930063de4e728c9b625057eca (diff)
Import libowfat
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/libowfat')
-rw-r--r--libs/libowfat/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/libs/libowfat/Makefile b/libs/libowfat/Makefile
new file mode 100644
index 000000000..3a0bcc310
--- /dev/null
+++ b/libs/libowfat/Makefile
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2010-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+LOWFAT_VERSION=0.28
+
+PKG_NAME:=libowfat
+PKG_VERSION:=$(LOWFAT_VERSION)
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://dl.fefe.de
+PKG_MD5SUM:=6bbee9a86506419657d87123b7a6f2c1
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+# set to 1 to enable debugging
+DEBUG=
+
+define Package/libowfat
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=reimplemented libdjb under GPL
+ URL:=http://www.fefe.de/libowfat/
+endef
+
+define Build/Configure
+endef
+
+TARGET_CFLAGS += $(FPIC)
+LOWFAT_MAKEOPTS = $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
+ DEBUG="$(DEBUG)" \
+ VERSION="$(LOWFAT_VERSION)" \
+ OS="Linux"
+
+# work around a nasty gcc bug
+ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
+ LOWFAT_MAKEOPTS += WOPTS=""
+endif
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) $(LOWFAT_MAKEOPTS)
+endef
+
+define Build/InstallDev
+ mkdir -p $(1)/usr/include/libowfat
+ $(CP) $(PKG_BUILD_DIR)/*.h $(1)/usr/include/libowfat
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/*.a $(1)/usr/lib
+endef
+
+$(eval $(call BuildPackage,libowfat))