aboutsummaryrefslogtreecommitdiff
path: root/libs/libowfat
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-11-06 16:42:33 +0100
committerRosen Penev <rosenp@gmail.com>2022-11-06 12:54:15 -0800
commit0c59c77c96ac33ba58fea17b75c958c56fe429bc (patch)
treefc9e22e2c2cc71ed0ce7307bba1ae580e0d02d80 /libs/libowfat
parentcfb4767098b56a21746da583babadf9ba2900da7 (diff)
libowfat: Fix compile with glibc 2.36
This fixes the following error message seen when compiling against glibc 2.36: from scan/scan_httpdate.c:3: include/sys/cdefs.h:338:65: error: macro "__has_attribute" requires an identifier 338 | #if __GNUC_PREREQ (3,2) || __glibc_has_attribute (__deprecated__) Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'libs/libowfat')
-rw-r--r--libs/libowfat/Makefile2
-rw-r--r--libs/libowfat/patches/012-remove-deprecated.patch16
2 files changed, 17 insertions, 1 deletions
diff --git a/libs/libowfat/Makefile b/libs/libowfat/Makefile
index e93262509..9f9fc742d 100644
--- a/libs/libowfat/Makefile
+++ b/libs/libowfat/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libowfat
PKG_VERSION:=0.32
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.fefe.de/libowfat
diff --git a/libs/libowfat/patches/012-remove-deprecated.patch b/libs/libowfat/patches/012-remove-deprecated.patch
new file mode 100644
index 000000000..49e3c824c
--- /dev/null
+++ b/libs/libowfat/patches/012-remove-deprecated.patch
@@ -0,0 +1,16 @@
+--- a/scan/scan_iso8601.c
++++ b/scan/scan_iso8601.c
+@@ -1,5 +1,4 @@
+ #define _GNU_SOURCE
+-#define __deprecated__
+ #include "scan.h"
+ #include "byte.h"
+ #include "case.h"
+--- a/scan/scan_httpdate.c
++++ b/scan/scan_httpdate.c
+@@ -1,5 +1,4 @@
+ #define _GNU_SOURCE
+-#define __deprecated__
+ #include "scan.h"
+ #include "byte.h"
+ #include "case.h"