aboutsummaryrefslogtreecommitdiff
path: root/libs/liboping/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-07-02 12:31:43 +0200
committerJo-Philipp Wich <jow@openwrt.org>2014-07-02 12:31:43 +0200
commit092733f241641f0a8ccadc4ee02e39069aa6b4a3 (patch)
treef7c775ee322c4602a4596689f905d2c14b7d69c5 /libs/liboping/Makefile
parent30512fec8e1b0cb57981968d2495f49df0f162a9 (diff)
liboping: import from oldpackages, add myself as maintainer, add license information
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/liboping/Makefile')
-rw-r--r--libs/liboping/Makefile84
1 files changed, 84 insertions, 0 deletions
diff --git a/libs/liboping/Makefile b/libs/liboping/Makefile
new file mode 100644
index 000000000..54b45474c
--- /dev/null
+++ b/libs/liboping/Makefile
@@ -0,0 +1,84 @@
+#
+# Copyright (C) 2009-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=liboping
+PKG_VERSION:=1.6.2
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=GPL-2.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://verplant.org/liboping/files
+PKG_MD5SUM:=64a6f31310093d2517cfe7f05aa011e0
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/liboping/Default
+ URL:=http://verplant.org/liboping/
+endef
+
+define Package/liboping
+$(call Package/liboping/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=C library to generate ICMP echo requests.
+endef
+
+define Package/oping
+$(call Package/liboping/Default)
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Send ICMP echo request to network hosts
+ DEPENDS+= +liboping
+endef
+
+define Package/noping
+$(call Package/liboping/Default)
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Ncurses application to send ICMP echo request to network hosts
+ DEPENDS+= +liboping +libncurses
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --without-perl-bindings \
+ --enable-shared \
+ --enable-static
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/oping.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboping.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/liboping/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboping.so.* $(1)/usr/lib/
+endef
+
+define Package/oping/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/oping $(1)/usr/bin/
+endef
+
+define Package/noping/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/noping $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,liboping))
+$(eval $(call BuildPackage,oping))
+$(eval $(call BuildPackage,noping))