aboutsummaryrefslogtreecommitdiff
path: root/libs/liboil
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2014-07-16 19:21:11 -0400
committerSteven Barth <steven@midlink.org>2014-07-19 14:08:11 +0200
commitd81d7ebe5ea866c74c8ee214eea77edbefd9d934 (patch)
tree94d9dc5bc38524a0bf886e2fdcdda6ea98ea2397 /libs/liboil
parentd32053b1a497263a4383f8317cc1b1ea0cc261c6 (diff)
Copy liboil package from old repository
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs/liboil')
-rw-r--r--libs/liboil/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/libs/liboil/Makefile b/libs/liboil/Makefile
new file mode 100644
index 000000000..d444f69d4
--- /dev/null
+++ b/libs/liboil/Makefile
@@ -0,0 +1,66 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=liboil
+PKG_VERSION:=0.3.17
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
+PKG_MD5SUM:=47dc734f82faeb2964d97771cfd2e701
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/liboil
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=simple functions optimized for various CPUs
+ URL:=http://liboil.freedesktop.org/wiki/
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+ DEPENDS:=+librt
+endef
+
+define Package/liboil/description
+ Liboil is a library of simple functions that are optimized for various CPUs.
+ These functions are generally loops implementing simple algorithms, such as
+ converting an array of N integers to floating-point numbers or multiplying
+ and summing an array of N numbers. Such functions are candidates for significant
+ optimization using various techniques, especially by using extended instructions
+ provided by modern CPUs (Altivec, MMX, SSE, etc.).
+endef
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+
+TARGET_CFLAGS += $(FPIC)
+
+# XXX: VFP_CFLAGS is set to '-mfpu=vfp' on arm by configure, but that breaks
+# final linking stages, so override it until we find why
+MAKE_FLAGS += \
+ VFP_CFLAGS="" \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/liboil-0.3/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/liboil-0.3.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/liboil/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,liboil))