aboutsummaryrefslogtreecommitdiff
path: root/libs/libogg
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-07-17 16:52:21 -0400
committerTed Hess <thess@kitschensync.net>2014-07-17 18:04:56 -0400
commit55a2b5176447b5fb3a2ea94d3f6d2351ad1b5718 (patch)
tree14278ff7e574825cbc95458b3b8c567295b7ce45 /libs/libogg
parentf218947804cf4fdfa99ab403332f7d7b0c8b267b (diff)
Import libogg from oldpackages
Diffstat (limited to 'libs/libogg')
-rw-r--r--libs/libogg/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/libs/libogg/Makefile b/libs/libogg/Makefile
new file mode 100644
index 000000000..7b3f588a4
--- /dev/null
+++ b/libs/libogg/Makefile
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2008-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libogg
+PKG_VERSION:=1.3.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ogg/
+PKG_MD5SUM:=ca25d8da0ddfc8c6cbbf78d847a209fe
+
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libogg
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=libogg
+ URL:=http://xiph.org/ogg/
+endef
+
+define Package/libogg/description
+Ogg project codecs use the Ogg bitstream format to arrange the raw,
+compressed bitstream into a more robust, useful form. For example,
+the Ogg bitstream makes seeking, time stamping and error recovery
+possible, as well as mixing several sepearate, concurrent media
+streams into a single physical bitstream.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/ogg/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/ogg/* $(1)/usr/include/ogg/
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DIR) $(1)/usr/share/aclocal/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+endef
+
+define Package/libogg/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libogg))