aboutsummaryrefslogtreecommitdiff
path: root/libs/libnvme/Makefile
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2023-07-11 14:01:16 +0000
committerTianling Shen <cnsztl@gmail.com>2023-07-18 21:26:46 +0800
commit06e9fdfe00727d31a01e97c9946d4148687b8edb (patch)
tree02d37d3a9c61b2033278e0e0ac964e62ab1569bc /libs/libnvme/Makefile
parentf33626819c3ff95dd7a70d7b6a7a7427c1456186 (diff)
nvme-cli: Add new package
Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Diffstat (limited to 'libs/libnvme/Makefile')
-rw-r--r--libs/libnvme/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/libs/libnvme/Makefile b/libs/libnvme/Makefile
new file mode 100644
index 000000000..0a459cc68
--- /dev/null
+++ b/libs/libnvme/Makefile
@@ -0,0 +1,57 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2023 Luca Barbato
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnvme
+PKG_VERSION:=1.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/linux-nvme/libnvme/archive/refs/tags/v$(PKG_VERSION)
+PKG_HASH:=f73ba1edde059b2d5e7c1048ad4f895e6047bff241c94b34a7aff5894779d086
+
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/meson.mk
+
+define Package/libnvme
+ SECTION:=utils
+ CATEGORY:=Libraries
+ SUBMENU:=Filesystem
+ TITLE:=C Library for NVM Express on Linux
+ URL:=https://github.com/linux-nvme/libnvme
+ DEPENDS:=+libjson-c
+endef
+
+define Package/libnvme/description
+ This is the libnvme development C library. libnvme provides type
+ definitions for NVMe specification structures, enumerations, and
+ bit fields, helper functions to construct, dispatch, and decode
+ commands and payloads, and utilities to connect, scan, and manage
+ nvme devices on a Linux system.
+endef
+
+MESON_ARGS += \
+ -Dopenssl=disabled -Dpython=disabled -Dlibdbus=disabled -Dkeyutils=disabled
+
+define Package/libnvme/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnvme*.so* $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/nvme
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/nvme/*.h $(1)/usr/include/nvme
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnvme*.so* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnvme*.pc $(1)/usr/lib/pkgconfig/
+endef
+
+$(eval $(call BuildPackage,libnvme))