aboutsummaryrefslogtreecommitdiff
path: root/libs/libnetfilter-acct
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-08-22 11:49:07 +0200
committerNicolas Thill <nico@openwrt.org>2014-08-23 10:56:10 +0200
commit2a3b9adae19e4a314cdb5a3e78c62d48994e8710 (patch)
tree203f4c54a5041221ec7fa7d590e907a62b21fa8b /libs/libnetfilter-acct
parent671fc5a58935bcbea381bd595de26d95ea89f283 (diff)
libnetfilter-acct: import new package
libnetfilter_acct is a userspace library providing a programming interface (API) to the extended accounting infrastructure. Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'libs/libnetfilter-acct')
-rw-r--r--libs/libnetfilter-acct/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/libs/libnetfilter-acct/Makefile b/libs/libnetfilter-acct/Makefile
new file mode 100644
index 000000000..028c23156
--- /dev/null
+++ b/libs/libnetfilter-acct/Makefile
@@ -0,0 +1,75 @@
+#
+# Copyright (C) 2009-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnetfilter_acct
+PKG_VERSION:=1.0.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/libnetfilter_acct/files/ \
+ ftp://ftp.netfilter.org/pub/libnetfilter_acct/ \
+ http://mirrors.evolva.ro/netfilter.org/libnetfilter_acct/
+PKG_MD5SUM:=2118d9514c079839ebd9cb3144ad2ad7
+
+PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE_FILE:=COPYING
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnetfilter-acct
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libmnl
+ TITLE:=API to extended accounting infrastructure
+ URL:=http://www.netfilter.org/projects/libnetfilter_acct/
+endef
+
+define Package/libnetfilter-acct/description
+ libnetfilter_acct is a userspace library providing a programming interface
+ (API) to the extended accounting infrastructure.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --enable-shared \
+
+CONFIGURE_VARS += \
+ LIBNFNETLINK_CFLAGS="$(TARGET_CPPFLAGS)" \
+ LIBNFNETLINK_LIBS="$(TARGET_LDFLAGS)"
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/libnetfilter_acct \
+ $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_acct*.{so*,a,la} \
+ $(1)/usr/lib/
+
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetfilter_acct.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libnetfilter-acct/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_acct.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnetfilter-acct))