aboutsummaryrefslogtreecommitdiff
path: root/libs/libmraa/patches/010-version.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-13 14:41:24 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-30 12:55:22 -0800
commitca4536b39ffb8dfed0a94687edb11426fb442ae5 (patch)
tree54eb886d3cdc3df854601588dfef2cc79fd40e33 /libs/libmraa/patches/010-version.patch
parent07e17bfe4a8760483548722b68edba2acd87902c (diff)
libmraa: Add several subpackages
Also added back the version patch to fix compilation with libupm. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libmraa/patches/010-version.patch')
-rw-r--r--libs/libmraa/patches/010-version.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/libs/libmraa/patches/010-version.patch b/libs/libmraa/patches/010-version.patch
new file mode 100644
index 000000000..55e06aa05
--- /dev/null
+++ b/libs/libmraa/patches/010-version.patch
@@ -0,0 +1,16 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -106,12 +106,7 @@ endif()
+ set (CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules ${CMAKE_MODULE_PATH})
+
+ # Make a version file containing the current version from git.
+-include (GetGitRevisionDescription)
+-git_describe (VERSION "--tags")
+-if ("x_${VERSION}" STREQUAL "x_GIT-NOTFOUND" OR "x_${VERSION}" STREQUAL "x_HEAD-HASH-NOTFOUND" OR "x_${VERSION}" STREQUAL "x_-128-NOTFOUND")
+- message (WARNING " - Install git to compile a production libmraa!")
+- set (VERSION "v2.0.0")
+-endif ()
++set (VERSION "v2.0.0")
+
+ message (STATUS "INFO - libmraa Version ${VERSION}")
+ message (STATUS "INFO - cmake Version ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION}")