aboutsummaryrefslogtreecommitdiff
path: root/libs/libmpeg2/Makefile
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2014-07-16 22:12:38 -0400
committerSteven Barth <steven@midlink.org>2014-07-19 14:08:11 +0200
commit45150b3585c67a931b6600e7c16092fe69d66306 (patch)
tree4bedbea6bef76417f23c662dbbfb4e7d23083d28 /libs/libmpeg2/Makefile
parentd81d7ebe5ea866c74c8ee214eea77edbefd9d934 (diff)
Copy libmpeg2 package from old repository
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs/libmpeg2/Makefile')
-rw-r--r--libs/libmpeg2/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/libs/libmpeg2/Makefile b/libs/libmpeg2/Makefile
new file mode 100644
index 000000000..9d3c05223
--- /dev/null
+++ b/libs/libmpeg2/Makefile
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libmpeg2
+PKG_VERSION:=0.5.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=libmpeg2-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://libmpeg2.sourceforge.net/files/
+PKG_MD5SUM:=0f92c7454e58379b4a5a378485bbd8ef
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libmpeg2
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=MPEG-1 & -2 decoding library
+ URL:=http://libmpeg2.sourceforge.net/
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+endef
+
+define Package/libmpeg2/decription
+ Libmpeg2 is a library for decoding MPEG-1 and MPEG-2 video streams
+endef
+
+CONFIGURE_ARGS += \
+ --disable-sdl \
+ --without-x \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/mpeg2dec \
+ $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libmpeg2{,convert}.{a,so*} \
+ $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libmpeg2{,convert}.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libmpeg2/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libmpeg2{,convert}.so.* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libmpeg2))