aboutsummaryrefslogtreecommitdiff
path: root/libs/libmodbus
diff options
context:
space:
mode:
authorKarl Palsson <karlp@remake.is>2014-09-08 14:51:15 +0000
committerKarl Palsson <karlp@remake.is>2014-09-09 10:13:46 +0000
commitc461550fbbe14e7c75c3cbbbf5b5da0374af65a6 (patch)
tree5ea3963ca4cfe9fea2c47238d3a11d51726e92ca /libs/libmodbus
parentfe13c18ebfa8ccb5a6b0bada424fb591f0f765f0 (diff)
Revert "libmodbus: revert to 2.0.4 to unbreak collectd support"
This reverts commit 98d5c3a15acb46ffa557afbda30f2760ad66168c. If collectd wants to stay on their own very outdated v4.10.x, that's fine, but they should not drag other packages down around with them. Support for modern versions of libmodbus has existed in collectd since v5.0.0, released 2011-03-28, so the actively maintained version of libmodbus in OpenWrt's modern package feed should remain at the modern versions in use by third party applications. This restores libmodbus to the existing version used throughout AA and BB prior to this collectd "fix" Signed-off-by: Karl Palsson <karlp@remake.is>
Diffstat (limited to 'libs/libmodbus')
-rw-r--r--libs/libmodbus/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/libs/libmodbus/Makefile b/libs/libmodbus/Makefile
index 159cce988..f8caab357 100644
--- a/libs/libmodbus/Makefile
+++ b/libs/libmodbus/Makefile
@@ -8,14 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libmodbus
-PKG_VERSION:=2.0.4
+PKG_VERSION:=3.0.6
PKG_RELEASE:=1
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/stephane/libmodbus.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=5881e70bc99a59fdb3466180e6eb1524b491d09d
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://libmodbus.org/releases
+PKG_MD5SUM:=c80f88b6ca19cabc4ceffc195ca07771
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -41,8 +39,8 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/modbus $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libmodbus.{so*,la} $(1)/usr/lib/
- # $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- # $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libmodbus.pc $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libmodbus.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libmodbus/install