aboutsummaryrefslogtreecommitdiff
path: root/libs/libmms/Makefile
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-07-17 17:37:59 -0400
committerTed Hess <thess@kitschensync.net>2014-07-17 18:04:56 -0400
commitfa3a88b23f372d7a906ad67da0cfe7b6c09e1c3b (patch)
tree5865644ec9bb08c6cc5d8adc7435abf88a542a14 /libs/libmms/Makefile
parent84728610f3b7eb086d825dcc858b4fca58c8f672 (diff)
libmms: Upgrade to 0.6.4, remove uneeded patch, fix build dependencies, add myself as pkg maintainer
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/libmms/Makefile')
-rw-r--r--libs/libmms/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/libs/libmms/Makefile b/libs/libmms/Makefile
index 28998a25b..8edec6648 100644
--- a/libs/libmms/Makefile
+++ b/libs/libmms/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libmms
-PKG_VERSION:=0.6
-PKG_RELEASE:=1
+PKG_VERSION:=0.6.4
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/libmms
-PKG_MD5SUM:=650ad04a4c8bd79246390b81b29680b6
+PKG_MD5SUM:=d6b665b335a6360e000976e770da7691
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=LGPLv2.1
PKG_LICENSE_FILES:=COPYING.LIB
@@ -30,6 +31,7 @@ define Package/libmms
DEPENDS:=+glib2
TITLE:=MMS stream protocol library
URL:=http://libmms.sourceforge.net
+ DEPENDS:=$(ICONV_DEPENDS)
endef
define Package/libmms/description
@@ -40,6 +42,7 @@ define Package/libmms/description
endef
TARGET_CFLAGS += $(FPIC)
+TARGET_LDFLAGS += $(if $(ICONV_FULL),-liconv)
define Build/Configure
(cd $(PKG_BUILD_DIR); ./autogen.sh );