aboutsummaryrefslogtreecommitdiff
path: root/libs/libmms/Makefile
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-07-17 16:52:21 -0400
committerTed Hess <thess@kitschensync.net>2014-07-17 18:04:56 -0400
commit55eeda5981128ce328816aa951a3fe9d9ac62ce4 (patch)
tree4c1b89f436b14410c22f7c70ea2f42976ab523db /libs/libmms/Makefile
parent55a2b5176447b5fb3a2ea94d3f6d2351ad1b5718 (diff)
Import libmms from oldpackages
Diffstat (limited to 'libs/libmms/Makefile')
-rw-r--r--libs/libmms/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/libs/libmms/Makefile b/libs/libmms/Makefile
new file mode 100644
index 000000000..28998a25b
--- /dev/null
+++ b/libs/libmms/Makefile
@@ -0,0 +1,65 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libmms
+PKG_VERSION:=0.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/libmms
+PKG_MD5SUM:=650ad04a4c8bd79246390b81b29680b6
+
+PKG_LICENSE:=LGPLv2.1
+PKG_LICENSE_FILES:=COPYING.LIB
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/libmms
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+glib2
+ TITLE:=MMS stream protocol library
+ URL:=http://libmms.sourceforge.net
+endef
+
+define Package/libmms/description
+ LibMMS is a common library for parsing mms:// and mmsh:// type network streams.
+ These are commonly used to stream Windows Media Video content over the web.
+ LibMMS itself is only for receiving MMS stream,
+ it doesn't handle sending at all.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/Configure
+ (cd $(PKG_BUILD_DIR); ./autogen.sh );
+ $(call Build/Configure/Default)
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libmms $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmms.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+ $(1)/usr/lib/pkgconfig
+endef
+
+define Package/libmms/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmms.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libmms))