aboutsummaryrefslogtreecommitdiff
path: root/libs/libmicrohttpd
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2016-11-21 16:46:28 +0100
committerAlexander Couzens <lynxis@fe80.eu>2016-11-30 17:42:58 +0100
commit55524f1b0aa923ed877e5af88351ec2877e53ee8 (patch)
treee707ba81348bcd2c4c6a246cbdc3a42267fe3e5a /libs/libmicrohttpd
parent9033f4ba92631538806217c51580e8185c1c5cb0 (diff)
libmicrohttpd: update to 0.9.52
Compile tested on x86_64. Runtime tested on x86_64. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'libs/libmicrohttpd')
-rw-r--r--libs/libmicrohttpd/Makefile4
-rw-r--r--libs/libmicrohttpd/patches/001-fix-inside-loop-deklaration.patch14
2 files changed, 2 insertions, 16 deletions
diff --git a/libs/libmicrohttpd/Makefile b/libs/libmicrohttpd/Makefile
index e992dc071..8b39084a3 100644
--- a/libs/libmicrohttpd/Makefile
+++ b/libs/libmicrohttpd/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libmicrohttpd
-PKG_VERSION:=0.9.50
+PKG_VERSION:=0.9.52
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/libmicrohttpd
-PKG_MD5SUM:=d1b6385068abded29b6470e383287aa7705de05ae3c08ad0bf5747ac4dc6ebd7
+PKG_MD5SUM:=54797f6e763d417627f89f60e4ae0a431dab0523f92f83def23ea02d0defafea
PKG_MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
diff --git a/libs/libmicrohttpd/patches/001-fix-inside-loop-deklaration.patch b/libs/libmicrohttpd/patches/001-fix-inside-loop-deklaration.patch
deleted file mode 100644
index e05530731..000000000
--- a/libs/libmicrohttpd/patches/001-fix-inside-loop-deklaration.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: libmicrohttpd-0.9.50/src/microhttpd/mhd_str.c
-===================================================================
---- libmicrohttpd-0.9.50.orig/src/microhttpd/mhd_str.c 2016-05-02 14:22:44.000000000 +0200
-+++ libmicrohttpd-0.9.50/src/microhttpd/mhd_str.c 2016-07-15 11:06:39.896282700 +0200
-@@ -271,7 +271,8 @@
- int
- MHD_str_equal_caseless_n_ (const char * const str1, const char * const str2, size_t maxlen)
- {
-- for (size_t i = 0; i < maxlen; ++i)
-+ size_t i;
-+ for (i = 0; i < maxlen; ++i)
- {
- const char c1 = str1[i];
- const char c2 = str2[i];