aboutsummaryrefslogtreecommitdiff
path: root/libs/libmicrohttpd
diff options
context:
space:
mode:
authorchamptar <champetier.etienne@gmail.com>2016-05-04 19:23:09 +0200
committerchamptar <champetier.etienne@gmail.com>2016-05-04 19:23:09 +0200
commit33843c23f1fc262ab635d7cba6b442ae7f40026c (patch)
tree177868375364cea800da2aab26020f688c764f5e /libs/libmicrohttpd
parent417ddf3061a92acb771f4406fa8d2bb04b6bf18d (diff)
parenta99aa1ff48dd18086039a325ad5bcc77a7eadaac (diff)
Merge pull request #2126 from lynxis/libmicrohttpd
Libmicrohttpd: add build variant for ssl + no-ssl + build parallel
Diffstat (limited to 'libs/libmicrohttpd')
-rw-r--r--libs/libmicrohttpd/Makefile52
1 files changed, 43 insertions, 9 deletions
diff --git a/libs/libmicrohttpd/Makefile b/libs/libmicrohttpd/Makefile
index 40ef8f9fb..fc29cb5e6 100644
--- a/libs/libmicrohttpd/Makefile
+++ b/libs/libmicrohttpd/Makefile
@@ -20,30 +20,59 @@ PKG_MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=COPYING
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
+
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+define Package/libmicrohttpd/Default
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=GNU libmicrohttpd is a library that runs an HTTP server.
+ URL:=http://www.gnu.org/software/libmicrohttpd/
+endef
+
define Package/libmicrohttpd
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=GNU libmicrohttpd is a library that runs an HTTP server.
- URL:=http://www.gnu.org/software/libmicrohttpd/
- DEPENDS:=+libpthread +libgcrypt +libgnutls +libgpg-error
+$(call Package/libmicrohttpd/Default)
+ TITLE+=(with-ssl)
+ DEPENDS:=+libpthread +libgcrypt +libgnutls +libgpg-error
+endef
+
+define Package/libmicrohttpd-no-ssl
+$(call Package/libmicrohttpd/Default)
+ TITLE+=(no-ssl)
+ DEPENDS:=+libpthread
+ VARIANT:=no-ssl
+ PROVIDES:=libmicrohttpd
+ CONFLICTS:=libmicrohttpd
endef
-define Package/libmicrohttpd/description
+define Package/libmicrohttpd/description/Default
GNU libmicrohttpd is a small C library that is supposed to make it easy
to run an HTTP server as part of another application.
endef
-CONFIGURE_ARGS += \
- --enable-https \
- --with-gnutls \
+define Package/libmicrohttpd-no-ssl/description
+$(call Package/libmicrohttp/description/Default)
+endef
+
+CONFIGURE_ARGS+= \
--disable-curl \
--disable-spdy \
--without-openssl
+ifeq ($(BUILD_VARIANT),no-ssl)
+CONFIGURE_ARGS += \
+ --disable-https \
+ --without-gnutls
+else
+CONFIGURE_ARGS += \
+ --enable-https \
+ --with-gnutls
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
@@ -58,4 +87,9 @@ define Package/libmicrohttpd/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
endef
+define Package/libmicrohttpd-no-ssl/install
+$(call Package/libmicrohttpd/install,$1)
+endef
+
$(eval $(call BuildPackage,libmicrohttpd))
+$(eval $(call BuildPackage,libmicrohttpd-no-ssl))