aboutsummaryrefslogtreecommitdiff
path: root/libs/libmicrohttpd
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2015-06-04 12:52:31 +0200
committerDaniel Golle <daniel@makrotopia.org>2015-06-25 23:25:46 +0200
commit24056cfdada751619439ea888ee7178f58c16f58 (patch)
tree266a717607be8a91de8274c4a14d7273fd5515db /libs/libmicrohttpd
parente14423f86690d61cff152058d9044d16321437be (diff)
libmicrohttpd: get rid of OpenSSL dependency
Depending on both, GnuTLS and OpenSSL doesn't make sense, we should use either TLS implementation but not both. Use GnuTLS for now and get rid of OpenSSL dependency by explicitely telling the package's build-system to do so using CONFIGURE_ARGS. If future uses of libmicrohttpd require OpenSSL, it probably makes most sense to build several variants of the package, i.e. libmicrohttpd-openssl as well as libmicrohttpd-gnutls. As with most packages making use of any TLS implementation, these are build-time decissions resulting in conflicting variants of the same package which cannot be installed simultanously. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/libmicrohttpd')
-rw-r--r--libs/libmicrohttpd/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/libs/libmicrohttpd/Makefile b/libs/libmicrohttpd/Makefile
index 2ea96f237..d47875cec 100644
--- a/libs/libmicrohttpd/Makefile
+++ b/libs/libmicrohttpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libmicrohttpd
PKG_VERSION:=0.9.42
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/libmicrohttpd
@@ -29,7 +29,7 @@ define Package/libmicrohttpd
CATEGORY:=Libraries
TITLE:=GNU libmicrohttpd is a library that runs an HTTP server.
URL:=http://www.gnu.org/software/libmicrohttpd/
- DEPENDS:=+libpthread +libgcrypt +libgnutls +libgpg-error +libopenssl
+ DEPENDS:=+libpthread +libgcrypt +libgnutls +libgpg-error
endef
define Package/libmicrohttpd/description
@@ -37,6 +37,13 @@ define Package/libmicrohttpd/description
to run an HTTP server as part of another application.
endef
+CONFIGURE_ARGS += \
+ --enable-https \
+ --with-gnutls \
+ --disable-curl \
+ --disable-spdy \
+ --without-openssl
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/