aboutsummaryrefslogtreecommitdiff
path: root/libs/libjpeg-turbo
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-03 13:21:13 -0700
committerRosen Penev <rosenp@gmail.com>2021-06-03 13:21:52 -0700
commit730c582d291960e4d9fde5c381fea5d0db9de756 (patch)
tree47f1d7ac37f12453fbc61e47ceddbfc1ba685ad0 /libs/libjpeg-turbo
parentbdb017dd402052c84838aaff25a893b07977f833 (diff)
libjpeg-turbo: fix compilation without NEON
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libjpeg-turbo')
-rw-r--r--libs/libjpeg-turbo/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/libs/libjpeg-turbo/Makefile b/libs/libjpeg-turbo/Makefile
index bc84e929b..ba29eb13c 100644
--- a/libs/libjpeg-turbo/Makefile
+++ b/libs/libjpeg-turbo/Makefile
@@ -62,6 +62,12 @@ CMAKE_OPTIONS += \
-DWITH_SIMD=O$(if $(findstring mips,$(CONFIG_ARCH)),FF,N) \
-DWITH_TURBOJPEG=OFF
+ifneq ($(findstring arm,$(CONFIG_ARCH)),)
+ifeq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
+ CMAKE_OPTIONS += -DWITH_SIMD=OFF
+endif
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/