aboutsummaryrefslogtreecommitdiff
path: root/libs/libinput/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2015-06-10 18:12:44 +0200
committerDaniel Golle <daniel@makrotopia.org>2015-06-10 18:17:48 +0200
commitca738e067ba0f00eed96f0e59a0041c0a108105f (patch)
tree5223620192caad1f1c01fd321da9cd69e7358ab3 /libs/libinput/Makefile
parent7fef81c10d8ac2ec1761b6166d24f5708fa27b4a (diff)
libinput: new package
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/libinput/Makefile')
-rw-r--r--libs/libinput/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/libs/libinput/Makefile b/libs/libinput/Makefile
new file mode 100644
index 000000000..f03e1dbec
--- /dev/null
+++ b/libs/libinput/Makefile
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2007-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libinput
+PKG_VERSION:=0.17.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://www.freedesktop.org/software/libinput/
+# PKG_MD5SUM:=debfcd5153558eba25a8e71eb2534ae8
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= -std=gnu99
+
+define Package/libinput
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=a library to handle input devices
+ URL:=http://freedesktop.org/wiki/Software/libinput/
+ DEPENDS:=+libevdev +mtdev +udev
+endef
+
+define Package/libinput/description
+ libinput is a library to handle input devices in Wayland compositors
+ and to provide a generic X.Org input driver. It provides device
+ detection, device handling, input device event processing and
+ abstraction so minimize the amount of custom input code compositors
+ need to provide the common set of functionality that users expect.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{la,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libinput/install
+ $(INSTALL_DIR) $(1)/usr/lib/udev
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/udev/* $(1)/usr/lib/udev
+endef
+
+$(eval $(call BuildPackage,libinput))