aboutsummaryrefslogtreecommitdiff
path: root/libs/libiio
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2020-09-14 21:49:14 +0200
committerMichael Heimpold <mhei@heimpold.de>2020-09-14 21:49:43 +0200
commitc16abfb3b5d535056ff151e0352b5ca13bf77057 (patch)
tree01418715dee83ffa67a2db025c2345e4d2457bc6 /libs/libiio
parent749e182ca18ee542e4c1a6634980c3289e15a737 (diff)
libiio: fix linker error when XML backend is not selected
It seems to be an upstream bug which prevents linking when XML backend is not selected: ../libiio.so.0.21: undefined reference to `encode_xml_ndup' Until this is clarified with upstream, prevent OpenWrt users from deselecting the XML backend. This increases the footprint of this package, but renders it usable again. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'libs/libiio')
-rw-r--r--libs/libiio/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/libs/libiio/Makefile b/libs/libiio/Makefile
index 1e0ff15f4..b694b18b7 100644
--- a/libs/libiio/Makefile
+++ b/libs/libiio/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libiio
PKG_VERSION:=0.21
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/analogdevicesinc/libiio/tar.gz/v$(PKG_VERSION)?
@@ -78,9 +78,9 @@ config LIBIIO_USB_BACKEND
default n
config LIBIIO_XML_BACKEND
- bool "Enable XML backend"
+ bool
depends on PACKAGE_libiio
- default n
+ default y
endef
define Package/libiio/description
@@ -101,7 +101,7 @@ define Package/iiod
CATEGORY:=Network
TITLE:=Linux IIO daemon
URL:=https://github.com/analogdevicesinc/libiio
- DEPENDS:=+libiio @LIBIIO_XML_BACKEND
+ DEPENDS:=+libiio
endef
define Package/iiod/description