aboutsummaryrefslogtreecommitdiff
path: root/libs/libiio
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2018-01-20 21:57:28 +0100
committerMichael Heimpold <mhei@heimpold.de>2018-01-20 22:03:09 +0100
commit6a55acc5197fa1e71c77e5d33d5f968b24a9f047 (patch)
treebf469d935c3e3ba4867f937d3d61352d05ea7539 /libs/libiio
parenteae25776a9d3e8a33728b9cd84dd8cf22cb7f823 (diff)
libiio: update to 0.12
- remove upstreamed patch - remove dependency to libavahi-common which does not exist, seems that I have confused library name vs package name (fixes #5480) (- only compile tested at the moment) Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'libs/libiio')
-rw-r--r--libs/libiio/Makefile8
-rw-r--r--libs/libiio/patches/001-quote-strequal.patch11
2 files changed, 4 insertions, 15 deletions
diff --git a/libs/libiio/Makefile b/libs/libiio/Makefile
index 4ed08e398..184d6cc69 100644
--- a/libs/libiio/Makefile
+++ b/libs/libiio/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiio
-PKG_VERSION:=0.11
-PKG_RELEASE:=2
+PKG_VERSION:=0.12
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/analogdevicesinc/libiio/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=0174111b028d84f18fb3716b22834a372a1f2575938f87e20e5cbd76747d0fdb
+PKG_HASH:=36e164fc00535762c819db209928ee2704fc81657d41060ea47873bccfd5c4bc
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=COPYING.txt
@@ -34,7 +34,7 @@ define Package/libiio
TITLE:=Library for interfacing with Linux IIO devices
URL:=https://github.com/analogdevicesinc/libiio
DEPENDS:=+PACKAGE_libaio:libaio +PACKAGE_libusb-1.0:libusb-1.0 \
- +PACKAGE_libavahi-common:libavahi-common +PACKAGE_libavahi-client:libavahi-client +libxml2
+ +PACKAGE_libavahi-client:libavahi-client +libxml2
endef
define Package/libiio/description
diff --git a/libs/libiio/patches/001-quote-strequal.patch b/libs/libiio/patches/001-quote-strequal.patch
deleted file mode 100644
index d8b91f89b..000000000
--- a/libs/libiio/patches/001-quote-strequal.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt 2017-10-23 22:24:46.000000000 +0200
-+++ b/CMakeLists.txt 2017-11-18 20:31:27.943838662 +0100
-@@ -111,7 +111,7 @@
- OUTPUT_STRIP_TRAILING_WHITESPACE
- )
-
-- if (${LIBIIO_GIT_REPO} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR})
-+ if ("${LIBIIO_GIT_REPO}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}")
- execute_process(
- COMMAND ${GIT_EXECUTABLE} rev-parse --short HEAD
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}