aboutsummaryrefslogtreecommitdiff
path: root/libs/libiio
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2017-11-18 20:41:39 +0100
committerMichael Heimpold <mhei@heimpold.de>2017-11-18 22:06:19 +0100
commit1c4f928f92df39846624e25cc718028a6813d692 (patch)
treef78d21ea739e4dc8565762b9fd228e4ae38ffc5c /libs/libiio
parentacef284695dd1e1bd43d0bc9e6940bb2bb1f966b (diff)
libiio: add patch to fix build on buildbots
On buildbots, the building directory seems to be not a subdir of a git repo, so a variable expands into an empty string which in turn results in a syntax error: --snip-- -- Looking for in6addr_any - found -- Found Git: /data/bowl-builder/arm_cortex-a5/build/sdk/staging_dir/host/bin/git (found version "2.1.4") fatal: Not a git repository (or any parent up to mount point /data) Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set). CMake Error at CMakeLists.txt:114 (if): if given arguments: "STREQUAL" "/data/bowl-builder/arm_cortex-a5/build/sdk/build_dir/target-arm_cortex-a5_musl_eabi/libiio-0.11" Unknown arguments specified -- Configuring incomplete, errors occurred! --snap-- The patch quotes the if arguments and thus fixes the build. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'libs/libiio')
-rw-r--r--libs/libiio/patches/001-quote-strequal.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/libs/libiio/patches/001-quote-strequal.patch b/libs/libiio/patches/001-quote-strequal.patch
new file mode 100644
index 000000000..d8b91f89b
--- /dev/null
+++ b/libs/libiio/patches/001-quote-strequal.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2017-10-23 22:24:46.000000000 +0200
++++ b/CMakeLists.txt 2017-11-18 20:31:27.943838662 +0100
+@@ -111,7 +111,7 @@
+ OUTPUT_STRIP_TRAILING_WHITESPACE
+ )
+
+- if (${LIBIIO_GIT_REPO} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR})
++ if ("${LIBIIO_GIT_REPO}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}")
+ execute_process(
+ COMMAND ${GIT_EXECUTABLE} rev-parse --short HEAD
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}