aboutsummaryrefslogtreecommitdiff
path: root/libs/libical/patches
diff options
context:
space:
mode:
authorJose Zapater <jzapater@gmail.com>2018-10-08 12:21:18 +0200
committerJose Zapater <jzapater@gmail.com>2018-10-08 12:21:18 +0200
commit36338682505dbe5624a6c2594247c08b340ba739 (patch)
treea716e023db5213bf24f5f106a82001cea7f178e9 /libs/libical/patches
parentb066a1e0b7a54ad78914fdd4d3d3812aca08baf0 (diff)
libical: update to version 3.0.4
Signed-off-by: Jose Zapater <jzapater@gmail.com>
Diffstat (limited to 'libs/libical/patches')
-rw-r--r--libs/libical/patches/001-disable-icu-and-bdb-support.patch83
1 files changed, 83 insertions, 0 deletions
diff --git a/libs/libical/patches/001-disable-icu-and-bdb-support.patch b/libs/libical/patches/001-disable-icu-and-bdb-support.patch
new file mode 100644
index 000000000..25598b70c
--- /dev/null
+++ b/libs/libical/patches/001-disable-icu-and-bdb-support.patch
@@ -0,0 +1,83 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1cc7180..295bc20 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -161,43 +161,43 @@ endif()
+ # libicu is highly recommended for RSCALE support
+ # libicu can be found at http://www.icu-project.org
+ # RSCALE info at http://tools.ietf.org/html/rfc7529
+-find_package(ICU)
+-set_package_properties(ICU PROPERTIES
+- TYPE RECOMMENDED
+- PURPOSE "For RSCALE (RFC7529) support"
+-)
+-add_feature_info(
+- "RSCALE support (RFC7529)"
+- ICU_FOUND
+- "build in RSCALE support"
+-)
+-if(ICU_FOUND)
+- set(REQUIRES_PRIVATE_ICU "Requires.private: icu-i18n") #for libical.pc
+- set(HAVE_LIBICU 1)
+- if(ICU_MAJOR_VERSION VERSION_GREATER 50)
+- set(HAVE_ICU_DANGI TRUE)
+- else()
+- set(HAVE_ICU_DANGI FALSE)
+- endif()
+-endif()
+-if(ICU_I18N_FOUND)
+- set(HAVE_LIBICU_I18N 1)
+-endif()
++# find_package(ICU)
++# set_package_properties(ICU PROPERTIES
++# TYPE RECOMMENDED
++# PURPOSE "For RSCALE (RFC7529) support"
++# )
++# add_feature_info(
++# "RSCALE support (RFC7529)"
++# ICU_FOUND
++# "build in RSCALE support"
++# )
++# if(ICU_FOUND)
++# set(REQUIRES_PRIVATE_ICU "Requires.private: icu-i18n") #for libical.pc
++# set(HAVE_LIBICU 1)
++# if(ICU_MAJOR_VERSION VERSION_GREATER 50)
++# set(HAVE_ICU_DANGI TRUE)
++# else()
++# set(HAVE_ICU_DANGI FALSE)
++# endif()
++# endif()
++# if(ICU_I18N_FOUND)
++# set(HAVE_LIBICU_I18N 1)
++# endif()
+
+ # compile in Berkeley DB support
+-find_package(BDB)
+-set_package_properties(BDB PROPERTIES
+- TYPE OPTIONAL
+- PURPOSE "For Berkeley DB storage support"
+-)
+-add_feature_info(
+- "Berkeley DB storage support"
+- BDB_FOUND
+- "build in support for Berkeley DB storage"
+-)
+-if(BDB_FOUND)
+- set(HAVE_BDB True)
+-endif()
++# find_package(BDB)
++# set_package_properties(BDB PROPERTIES
++# TYPE OPTIONAL
++# PURPOSE "For Berkeley DB storage support"
++# )
++# add_feature_info(
++# "Berkeley DB storage support"
++# BDB_FOUND
++# "build in support for Berkeley DB storage"
++# )
++# if(BDB_FOUND)
++# set(HAVE_BDB True)
++# endif()
+
+ # MSVC specific definitions
+ if(WIN32)