aboutsummaryrefslogtreecommitdiff
path: root/libs/libhttp-parser/patches
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2019-07-29 17:45:22 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2019-07-29 17:45:22 +0900
commit5b76339f09dfe0af670b78bd86beaeac47df5510 (patch)
tree38f872d0261d33360016e7adbe4b5c2564cb4927 /libs/libhttp-parser/patches
parent1739260574f3c4eec8c03f90a58f5a904c11597c (diff)
libhttp-parser: fix build error on macos
Maintainer: @ageekymonk, me Compile tested: head r10622-e09da01,ath79,arm_cortex-a9+vfpv3,mipsel Run tested: mipsel Description: fix build error on macos https://github.com/openwrt/packages/issues/9587 Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
Diffstat (limited to 'libs/libhttp-parser/patches')
-rw-r--r--libs/libhttp-parser/patches/000-fix_darwin_error.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/libs/libhttp-parser/patches/000-fix_darwin_error.patch b/libs/libhttp-parser/patches/000-fix_darwin_error.patch
new file mode 100644
index 000000000..6937b5e58
--- /dev/null
+++ b/libs/libhttp-parser/patches/000-fix_darwin_error.patch
@@ -0,0 +1,51 @@
+--- a/Makefile
++++ b/Makefile
+@@ -25,11 +25,7 @@
+ SOMAJOR = 2
+ SOMINOR = 9
+ SOREV = 2
+-ifeq (darwin,$(PLATFORM))
+-SOEXT ?= dylib
+-SONAME ?= $(SOLIBNAME).$(SOMAJOR).$(SOMINOR).$(SOEXT)
+-LIBNAME ?= $(SOLIBNAME).$(SOMAJOR).$(SOMINOR).$(SOREV).$(SOEXT)
+-else ifeq (wine,$(PLATFORM))
++ifeq (wine,$(PLATFORM))
+ CC = winegcc
+ BINEXT = .exe.so
+ HELPER = wine
+@@ -65,12 +61,8 @@
+ LIBDIR = $(PREFIX)/lib
+ INCLUDEDIR = $(PREFIX)/include
+
+-ifeq (darwin,$(PLATFORM))
+-LDFLAGS_LIB += -Wl,-install_name,$(LIBDIR)/$(SONAME)
+-else
+ # TODO(bnoordhuis) The native SunOS linker expects -h rather than -soname...
+ LDFLAGS_LIB += -Wl,-soname=$(SONAME)
+-endif
+
+ test: test_g test_fast
+ $(HELPER) ./test_g$(BINEXT)
+@@ -131,14 +123,18 @@
+ ctags $^
+
+ install: library
+- $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
+- $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
++ $(INSTALL) -d $(DESTDIR)$(INCLUDEDIR)
++ $(INSTALL) -d $(DESTDIR)$(LIBDIR)
++ $(INSTALL) http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
++ $(INSTALL) $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
+ ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+ ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)
+
+ install-strip: library
+- $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
+- $(INSTALL) -D -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
++ $(INSTALL) -d $(DESTDIR)$(INCLUDEDIR)
++ $(INSTALL) -d $(DESTDIR)$(LIBDIR)
++ $(INSTALL) http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
++ $(INSTALL) -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
+ ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+ ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)
+