aboutsummaryrefslogtreecommitdiff
path: root/libs/libgpiod
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-12-21 14:18:47 +0100
committerFlorian Eckert <fe@dev.tdt.de>2022-12-23 13:43:32 +0100
commit4dfb0024f4fcaec0f7eaac5d7abc1126959548e9 (patch)
tree2e48bec606d9c923963a304b5bce46008be12101 /libs/libgpiod
parentdf0b2eedd6d0b7f81851860afdee1b135850c115 (diff)
libgpiod: add missing kernel build options via KCONFIG
This library needs the kernel config option 'CONFIG_GPIO_CDEV_V1=y' to be set. If this is not set, the tool 'gpioinfo' produces the error message 'error creating line iterator'. Add the missing kernel config option to build CDEV with API Version 1 fixes this. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'libs/libgpiod')
-rw-r--r--libs/libgpiod/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/libs/libgpiod/Makefile b/libs/libgpiod/Makefile
index a5ece1031..9859dca27 100644
--- a/libs/libgpiod/Makefile
+++ b/libs/libgpiod/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libgpiod
PKG_VERSION:=1.6.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/libs/libgpiod/
@@ -43,6 +43,9 @@ define Package/libgpiod
CATEGORY:=Libraries
URL:=https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git
TITLE:=Library for interacting with Linux's GPIO character device
+ KCONFIG:= \
+ CONFIG_GPIO_CDEV=y \
+ CONFIG_GPIO_CDEV_V1=y
DEPENDS:=@GPIO_SUPPORT
endef