aboutsummaryrefslogtreecommitdiff
path: root/libs/libgpg-error
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-10-20 19:31:07 +0100
committerDaniel Golle <dangowrt@users.noreply.github.com>2020-11-07 15:51:49 +0000
commit186d7e4a61a8d89aa2ec266a8c9accc0d1342e96 (patch)
treeb27ea0fee23016b0652a9dc4e96f440a54712b43 /libs/libgpg-error
parent4385a85a260b2212d552654c732296f47ad9a36c (diff)
libgpg-error: make gpgrt.h available for depending packages
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/libgpg-error')
1 files changed, 17 insertions, 1 deletions
diff --git a/libs/libgpg-error/Makefile b/libs/libgpg-error/Makefile
index 0e66164e0..868595c35 100644
--- a/libs/libgpg-error/Makefile
+++ b/libs/libgpg-error/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libgpg-error
PKG_VERSION:=1.37
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://mirrors.dotsrc.org/gcrypt/libgpg-error \
@@ -60,11 +60,23 @@ define Build/InstallDev
$(2)/bin/gpg-error-config
ln -sf $(STAGING_DIR)/host/bin/gpg-error-config $(1)/usr/bin/gpg-error-config
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/bin/gpgrt-config \
+ $(2)/bin/
+ $(SED) \
+ 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+ $(2)/bin/gpgrt-config
+ ln -sf $(STAGING_DIR)/host/bin/gpgrt-config $(1)/usr/bin/gpgrt-config
+
$(INSTALL_DIR) $(1)/usr/include
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/include/gpg-error.h \
$(1)/usr/include/
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/include/gpgrt.h \
+ $(1)/usr/include/
+
$(INSTALL_DIR) $(1)/usr/lib
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libgpg-error.{la,a,so*} \
@@ -74,6 +86,10 @@ define Build/InstallDev
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/share/aclocal/gpg-error.m4 \
$(1)/usr/share/aclocal/
+
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/share/aclocal/gpgrt.m4 \
+ $(1)/usr/share/aclocal/
endef
define Package/libgpg-error/install