aboutsummaryrefslogtreecommitdiff
path: root/libs/libgee/Makefile
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2015-10-18 22:20:29 -0400
committerW. Michael Petullo <mike@flyn.org>2015-10-18 22:20:29 -0400
commit10f280c3144b20c7233ab26640b64207e7b8ccfc (patch)
tree00c6a36acac96682ec4aeeabf204cc38e7f9fb12 /libs/libgee/Makefile
parent59fcc276d5d00d4639820c254f55c7aac2d5a839 (diff)
libgee: add new package
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs/libgee/Makefile')
-rw-r--r--libs/libgee/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/libs/libgee/Makefile b/libs/libgee/Makefile
new file mode 100644
index 000000000..87705e3df
--- /dev/null
+++ b/libs/libgee/Makefile
@@ -0,0 +1,69 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libgee
+PKG_VERSION:=0.18.0
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://download.gnome.org/sources/libgee/0.18/
+PKG_MD5SUM:=29ea6125e653d7e60b49a9a9544abc96
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+TARGET_LDFLAGS+= \
+ -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/libgee
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+glib2
+ TITLE:=libgee
+ URL:=https://wiki.gnome.org/Libgee
+endef
+
+define Package/libgee/decription
+ Libgee is an utility library providing GObject-based interfaces and classes
+endef
+
+CONFIGURE_ARGS += \
+ --disable-doc
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/gee-0.8/ \
+ $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+ $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libgee/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libgee))