aboutsummaryrefslogtreecommitdiff
path: root/libs/libgd
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2020-01-04 10:07:04 -0500
committerW. Michael Petullo <mike@flyn.org>2020-01-04 19:12:43 -0500
commit7bd2a149ff3a1afa95d7feed5bbb5bf1958237fd (patch)
treeddf6c908fd74cc6e5f31bec6502de1011d0daec6 /libs/libgd
parent2628584ffd0e8b28aa3d5e11966dc61a48153da4 (diff)
libgd: fix building with freetype support
Freetype support is required for php7-mod-gd as of commit 0f10c8c8, which causes the PHP7 package to build using this external libgd library. This commit adds FREETYPE_INCLUDE_DIRS to the definition of CMAKE_OPTIONS. Without this, libgd does not build freetype support as shown by this message: .... Build libgd: -- Could NOT find Freetype (missing: FREETYPE_INCLUDE_DIRS) -- Configuring done -- Generating done .... Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs/libgd')
-rw-r--r--libs/libgd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/libgd/Makefile b/libs/libgd/Makefile
index 6dfe81df4..67c22105b 100644
--- a/libs/libgd/Makefile
+++ b/libs/libgd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libgd
PKG_VERSION:=2.2.5
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME)/releases/download/gd-$(PKG_VERSION)/
@@ -79,6 +79,7 @@ endif
ifdef CONFIG_LIBGD_FREETYPE
CMAKE_OPTIONS += \
+ -DFREETYPE_INCLUDE_DIRS=$(STAGING_DIR)/usr/include/freetype2/ \
-DENABLE_FREETYPE=ON
else
CMAKE_OPTIONS += \