aboutsummaryrefslogtreecommitdiff
path: root/libs/libffi
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-08-13 22:01:11 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2017-08-26 09:41:24 +0300
commite3b2ef74e9797d9e3537ff1dac612afa7919a64c (patch)
tree26d0976b78e69030b45dc0bae6cfda2a3c4ad2de /libs/libffi
parentff37357fb50fdd74d04fa59ece901abbac61f07b (diff)
libffi: fix install location of host libffi headers
Seems that the header files for the host libffi headers are installed in the wrong place. i.e. $(STAGING_DIR_HOSTPKG)/lib/libffi-3.2.1/include when it should be $(STAGING_DIR_HOSTPKG)/include Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'libs/libffi')
-rw-r--r--libs/libffi/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/libs/libffi/Makefile b/libs/libffi/Makefile
index a967d6aca..be1763c93 100644
--- a/libs/libffi/Makefile
+++ b/libs/libffi/Makefile
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libffi
PKG_VERSION:=3.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://sourceware.org/pub/libffi/
-PKG_MD5SUM:=83b89587607e3eb65c70d361f13bab43
+PKG_HASH:=d06ebb8e1d9a22d19e38d63fdb83954253f39bedc5d46232a05645685722ca37
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
@@ -78,5 +78,15 @@ define Package/libffi/install
$(1)/usr/lib/
endef
+define Host/Install
+ $(call Host/Install/Default)
+ # Adjust host libffi headers ; the default rule does
+ # not seem to install them to the proper include folder
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/include
+ $(CP) \
+ $(STAGING_DIR_HOSTPKG)/lib/libffi-$(PKG_VERSION)/include/*.h \
+ $(STAGING_DIR_HOSTPKG)/include
+endef
+
$(eval $(call HostBuild))
$(eval $(call BuildPackage,libffi))