aboutsummaryrefslogtreecommitdiff
path: root/libs/libfastjson
diff options
context:
space:
mode:
authorDov Murik <dmurik@us.ibm.com>2016-03-25 14:03:53 -0400
committerDov Murik <dmurik@us.ibm.com>2016-03-25 14:03:53 -0400
commit40daf44e619e32a3156400b8bd6c1f6160b29b97 (patch)
treeda3a787353e6b85f27d2b2c0e5407e4fa6016b57 /libs/libfastjson
parent4457604f3b1c5fa4e76ddf23dc69bf0c312bc923 (diff)
Add libs/libfastjson - required for rsyslog 8.17.0
Diffstat (limited to 'libs/libfastjson')
-rw-r--r--libs/libfastjson/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/libs/libfastjson/Makefile b/libs/libfastjson/Makefile
new file mode 100644
index 000000000..8d38219be
--- /dev/null
+++ b/libs/libfastjson/Makefile
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libfastjson
+PKG_VERSION:=0.99.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://github.com/rsyslog/libfastjson.git
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
+
+PKG_MAINTAINER:=Dov Murik <dmurik@us.ibm.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILE:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libfastjson
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A fast JSON library for C
+ URL:=https://github.com/rsyslog/libfastjson
+endef
+
+define Package/libfastjson/description
+ libfastjson - A fast JSON library for C
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+endef
+
+define Package/libfastjson/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfastjson.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libfastjson))