aboutsummaryrefslogtreecommitdiff
path: root/libs/libevent
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-06-23 15:29:44 +0200
committerSteven Barth <steven@midlink.org>2014-06-23 15:30:15 +0200
commit6c0f9011d96e1bfb4d2d73acd50cecc1d639c3f9 (patch)
treec63b474f5e4d7189d15d723236c047b5cfa7a0a2 /libs/libevent
parent63782c633da921cae59465268545af58fc9f906c (diff)
libevent: import from oldpackages
Signed-off-by: Steven Barth <steven@midlink.org>
Diffstat (limited to 'libs/libevent')
-rw-r--r--libs/libevent/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/libs/libevent/Makefile b/libs/libevent/Makefile
new file mode 100644
index 000000000..c1ec4b604
--- /dev/null
+++ b/libs/libevent/Makefile
@@ -0,0 +1,67 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libevent
+PKG_VERSION:=1.4.14b
+PKG_RELEASE:=2
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable.tar.gz
+PKG_SOURCE_URL:=https://github.com/downloads/libevent/libevent/
+PKG_MD5SUM:=a00e037e4d3f9e4fe9893e8a2d27918c
+PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libevent
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Event notification library
+ DEPENDS:=+librt
+ URL:=http://www.libevent.org
+endef
+
+define Package/libevent/description
+ The libevent API provides a mechanism to execute a callback function
+ when a specific event occurs on a file descriptor or after a timeout
+ has been reached. Furthermore, libevent also support callbacks due
+ to signals or regular timeouts.
+
+ libevent is meant to replace the event loop found in event driven
+ network servers. An application just needs to call event_dispatch()
+ and then add or remove events dynamically without having to change
+ the event loop.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+
+MAKE_FLAGS += \
+ CFLAGS="$(TARGET_CFLAGS)" \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/libevent
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/libevent/
+ $(INSTALL_DIR) $(1)/usr/lib/libevent
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{a,so} $(1)/usr/lib/libevent/
+endef
+
+define Package/libevent/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libevent))