aboutsummaryrefslogtreecommitdiff
path: root/libs/libevdev/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2015-06-10 18:12:20 +0200
committerDaniel Golle <daniel@makrotopia.org>2015-06-10 18:17:47 +0200
commit615e26e4463ce01c9971c21e621fbf01d2e7fb5f (patch)
treec2fd295e79af88fc8b26aa25f6d95a34f0cf4ff6 /libs/libevdev/Makefile
parent7f9c9bff6118faf40d545095af4cb5535d71f264 (diff)
libevdev: new package
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/libevdev/Makefile')
-rw-r--r--libs/libevdev/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/libs/libevdev/Makefile b/libs/libevdev/Makefile
new file mode 100644
index 000000000..2fe243331
--- /dev/null
+++ b/libs/libevdev/Makefile
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2007-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libevdev
+PKG_VERSION:=1.4.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://www.freedesktop.org/software/libevdev/
+PKG_MD5SUM:=debfcd5153558eba25a8e71eb2534ae8
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libevdev
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=a wrapper library for evdev devices
+ URL:=http://www.freedesktop.org/wiki/Software/libevdev/
+endef
+
+define Package/libevdev/description
+ libevdev is a wrapper library for evdev devices. it moves the common
+ tasks when dealing with evdev devices into a library and provides a
+ library interface to the callers, thus avoiding erroneous ioctls, etc.
+
+ The eventual goal is that libevdev wraps all ioctls available to
+ evdev devices, thus making direct access unnecessary.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libevdev/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libevdev))