aboutsummaryrefslogtreecommitdiff
path: root/libs/libestr/Makefile
diff options
context:
space:
mode:
authorDov Murik <dmurik@us.ibm.com>2015-11-03 16:16:51 -0500
committerDov Murik <dmurik@us.ibm.com>2015-11-11 10:00:12 -0500
commit964835bccd16717e2d65d3cbe8f213183b978eec (patch)
tree36be9324206dedd953776b7c73a01d8362897242 /libs/libestr/Makefile
parent726e9dcafd3645928b8ca338e6ef4691cb699350 (diff)
libs/libestr: add new package (needed for net/rsyslog)
Signed-off-by: Dov Murik <dmurik@us.ibm.com>
Diffstat (limited to 'libs/libestr/Makefile')
-rw-r--r--libs/libestr/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/libs/libestr/Makefile b/libs/libestr/Makefile
new file mode 100644
index 000000000..9a551f9a5
--- /dev/null
+++ b/libs/libestr/Makefile
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libestr
+PKG_VERSION:=0.1.10
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://libestr.adiscon.com/files/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=f4c9165a23587e77f7efe65d676d5e8e
+
+PKG_MAINTAINER:=Dov Murik <dmurik@us.ibm.com>
+PKG_LICENSE:=LGPL-2.1+
+PKG_LICENSE_FILE:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libestr
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=String handling library
+ URL:=http://libestr.adiscon.com/
+endef
+
+define Package/libestr/description
+ libestr - some essentials for string handling (and a bit more)
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+endef
+
+define Package/libestr/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libestr.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libestr))