diff options
author | Paul Fertser <fercerpav@gmail.com> | 2023-04-21 16:32:27 +0000 |
---|---|---|
committer | Paul Spooren <mail@aparcar.org> | 2023-04-21 22:46:58 +0200 |
commit | 0c10c224be81f9221dabfab449855ab6718d2a0c (patch) | |
tree | c7e9f983c60cbf9ae17bce5f64dc72963c67a6d3 /libs/libdvbcsa | |
parent | 018fcf3ccd3c65c92f7c9467ab35f345fbd2c1ae (diff) |
treewide: remove AUTORELEASE
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used.
The following temporary change was made to the core:
diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))
COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))
all:
FORCE: ;
And this command used to fix affected packages:
for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
sed 's^.*/\([^/]*\)/Makefile^\1^';);
do
make package/$i/download
done
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'libs/libdvbcsa')
-rw-r--r-- | libs/libdvbcsa/Makefile | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/libs/libdvbcsa/Makefile b/libs/libdvbcsa/Makefile index 1976ce04d..62a89e9ca 100644 --- a/libs/libdvbcsa/Makefile +++ b/libs/libdvbcsa/Makefile @@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk PKG_NAME:=libdvbcsa -PKG_RELEASE:=$(AUTORELEASE) +PKG_RELEASE:=2 PKG_SOURCE_VERSION:=bc6c0b164a87ce05e9925785cc6fb3f54c02b026 PKG_HASH:=2d761c9e094642f2c9aa7e66534c6147a59d0d0bc709ec0f2fdbb34bf020d8ec |