aboutsummaryrefslogtreecommitdiff
path: root/libs/libdrm/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-11-04 20:58:07 -0700
committerRosen Penev <rosenp@gmail.com>2022-11-05 17:59:06 -0700
commit5542f91918c16cbe358dcaccad1b2233db7ecc4a (patch)
tree6fa94bc8344110cc533a4ef8ec4b17f5e59cdc65 /libs/libdrm/Makefile
parent6b49eeb0938e0dd6dab518e4759fc2e4402de344 (diff)
libdrm: update to 2.4.114
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libdrm/Makefile')
-rw-r--r--libs/libdrm/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/libs/libdrm/Makefile b/libs/libdrm/Makefile
index 7356ba0dd..2032cee25 100644
--- a/libs/libdrm/Makefile
+++ b/libs/libdrm/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libdrm
-PKG_VERSION:=2.4.107
+PKG_VERSION:=2.4.114
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://dri.freedesktop.org/libdrm
-PKG_HASH:=c554cef03b033636a975543eab363cc19081cb464595d3da1ec129f87370f888
+PKG_HASH:=3049cf843a47d12e5eeefbc3be3496d782fa09f42346bf0b7defe3d1e598d026
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
PKG_LICENSE:=BSD-3-Clause
@@ -43,20 +43,20 @@ define Package/libdrm/config
endef
MESON_ARGS += \
- $(if $(CONFIG_LIBDRM_INTEL),-Dintel=true -Dlibkms=true,-Dintel=false -Dlibkms=false) \
- -Dradeon=$(if $(CONFIG_LIBDRM_RADEON),true,false) \
- -Damdgpu=false \
- -Dnouveau=$(if $(CONFIG_LIBDRM_NOUVEAU),true,false) \
- -Dvmwgfx=false \
- -Domap=false \
- -Dexynos=false \
- -Dfreedreno=false \
- -Dtegra=false \
- -Dvc4=false \
- -Detnaviv=false \
- -Dcairo-tests=false \
- -Dman-pages=false \
- -Dvalgrind=false \
+ -Dintel=$(if $(CONFIG_LIBDRM_INTEL),en,dis)abled \
+ -Dradeon=$(if $(CONFIG_LIBDRM_RADEON),en,dis)abled \
+ -Damdgpu=disabled \
+ -Dnouveau=$(if $(CONFIG_LIBDRM_NOUVEAU),en,dis)abled \
+ -Dvmwgfx=disabled \
+ -Domap=disabled \
+ -Dexynos=disabled \
+ -Dfreedreno=disabled \
+ -Dtegra=disabled \
+ -Dvc4=disabled \
+ -Detnaviv=disabled \
+ -Dcairo-tests=disabled \
+ -Dman-pages=disabled \
+ -Dvalgrind=disabled \
-Dfreedreno-kgsl=false \
-Dinstall-test-programs=false \
-Dudev=false