aboutsummaryrefslogtreecommitdiff
path: root/libs/libdrm/Makefile
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2021-02-28 11:24:16 +0100
committerBernd Kuhls <bernd.kuhls@t-online.de>2021-03-01 07:04:01 +0100
commit240af18f30896724d54ee0ba6645d02f0b5ee778 (patch)
tree091dc242a3b786615fbd1228fd248f6b3413d935 /libs/libdrm/Makefile
parent55ed772eba2b7e47e78d22b954b6ef18a59aed43 (diff)
libdrm: add option to build the nouveau and radeon driver
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Diffstat (limited to 'libs/libdrm/Makefile')
-rw-r--r--libs/libdrm/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/libs/libdrm/Makefile b/libs/libdrm/Makefile
index 669b8956c..206748878 100644
--- a/libs/libdrm/Makefile
+++ b/libs/libdrm/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libdrm
PKG_VERSION:=2.4.104
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://dri.freedesktop.org/libdrm
@@ -17,7 +17,9 @@ PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
PKG_LICENSE:=BSD-3-Clause
PKG_CONFIG_DEPENDS:= \
- CONFIG_LIBDRM_INTEL
+ CONFIG_LIBDRM_INTEL \
+ CONFIG_LIBDRM_NOUVEAU \
+ CONFIG_LIBDRM_RADEON
PKG_INSTALL:=1
PKG_BUILD_DEPENDS:=meson/host
@@ -45,9 +47,9 @@ endef
MESON_ARGS += \
$(if $(CONFIG_LIBDRM_INTEL),-Dintel=true -Dlibkms=true,-Dintel=false -Dlibkms=false) \
- -Dradeon=false \
+ -Dradeon=$(if $(CONFIG_LIBDRM_RADEON),true,false) \
-Damdgpu=false \
- -Dnouveau=false \
+ -Dnouveau=$(if $(CONFIG_LIBDRM_NOUVEAU),true,false) \
-Dvmwgfx=false \
-Domap=false \
-Dexynos=false \