aboutsummaryrefslogtreecommitdiff
path: root/libs/libdnet
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-04 16:20:34 -0700
committerRosen Penev <rosenp@gmail.com>2021-10-05 17:33:14 -0700
commit6713d9e6620b398a36a1a8830ee91919b0f16956 (patch)
treeaf958a2fe521ce9d7347cd412f45fda563f955fd /libs/libdnet
parentda42cf7071ba1a95056bdd913e8a6362da7b1cf7 (diff)
libdnet: fix compilation under macOS
configure checks the host system not the target one. Override these variables. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libdnet')
-rw-r--r--libs/libdnet/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/libs/libdnet/Makefile b/libs/libdnet/Makefile
index 5b77b0449..52f179751 100644
--- a/libs/libdnet/Makefile
+++ b/libs/libdnet/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libdnet
PKG_VERSION:=1.14
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ofalk/libdnet/tar.gz/$(PKG_NAME)-$(PKG_VERSION)?
@@ -42,6 +42,10 @@ CONFIGURE_ARGS += \
--without-python \
--without-wpdpack
+CONFIGURE_VARS += \
+ ac_cv_dnet_bsd_bpf=no \
+ ac_cv_dnet_linux_pf_packet=yes
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dnet-config $(1)/usr/bin/