aboutsummaryrefslogtreecommitdiff
path: root/libs/libdaq
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-01-19 22:06:34 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 20:42:03 -0300
commit48e2b6ebb3ebb688de1c8a069c7b43d9478b3298 (patch)
treeba6b77db66b42d4300cfc7d80742b7d289591b2e /libs/libdaq
parentd8203191cc9ee7d74d8304eb8c6d1954789a0c12 (diff)
libdaq,snort: install/use libdaq2 in its own dir
If used with default paths, libdaq 2.x and libdaq 3.x will overwrite some of the other version's files. Install them in different places to avoid trouble. Snort is the only package that uses libdaq, so update it at the same time to avoid creating a failing commit. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'libs/libdaq')
-rw-r--r--libs/libdaq/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/libs/libdaq/Makefile b/libs/libdaq/Makefile
index 808c78472..b4bd7d8e2 100644
--- a/libs/libdaq/Makefile
+++ b/libs/libdaq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libdaq
PKG_VERSION:=2.2.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=https://www.snort.org/downloads/snortplus/
PKG_SOURCE:=daq-$(PKG_VERSION).tar.gz
@@ -45,12 +45,12 @@ CONFIGURE_ARGS+= \
--with-libpcap-libraries="$(STAGING_DIR)/usr/lib" \
define Build/InstallDev
- $(INSTALL_DIR) $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(STAGING_DIR)/usr/include/
- $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(STAGING_DIR)/usr/lib/
- $(INSTALL_DIR) $(STAGING_DIR)/usr/lib/daq
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/daq/* $(STAGING_DIR)/usr/lib/daq/
+ $(INSTALL_DIR) $(STAGING_DIR)/usr/include/daq2
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(STAGING_DIR)/usr/include/daq2/
+ $(INSTALL_DIR) $(STAGING_DIR)/usr/lib/daq2
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(STAGING_DIR)/usr/lib/daq2/
+ $(INSTALL_DIR) $(STAGING_DIR)/usr/lib/daq2/daq
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/daq/* $(STAGING_DIR)/usr/lib/daq2/daq/
$(INSTALL_DIR) $(STAGING_DIR)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/daq-modules-config $(STAGING_DIR)/usr/bin/
$(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(STAGING_DIR)/usr/bin/daq-modules-config