aboutsummaryrefslogtreecommitdiff
path: root/libs/libdaq
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-07 18:59:29 -0800
committerRosen Penev <rosenp@gmail.com>2020-12-07 20:17:05 -0800
commit33631ab9ffe67839bba7b703b754f601c5b9039f (patch)
tree1da6728be89625568bd5adb794993c20b7c2105f /libs/libdaq
parentea80600e3c390025b617aa8b25382c228f4c5b01 (diff)
libdaq: fix config file
Install to host to fix compilation with depending packages. Fix paths to point to OpenWrt and not OS. Don't install to device. This is strictly an InstallDev thing. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libdaq')
-rw-r--r--libs/libdaq/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/libs/libdaq/Makefile b/libs/libdaq/Makefile
index 2f37f00c2..808c78472 100644
--- a/libs/libdaq/Makefile
+++ b/libs/libdaq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libdaq
PKG_VERSION:=2.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://www.snort.org/downloads/snortplus/
PKG_SOURCE:=daq-$(PKG_VERSION).tar.gz
@@ -53,6 +53,9 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/daq/* $(STAGING_DIR)/usr/lib/daq/
$(INSTALL_DIR) $(STAGING_DIR)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/daq-modules-config $(STAGING_DIR)/usr/bin/
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(STAGING_DIR)/usr/bin/daq-modules-config
+ $(INSTALL_DIR) $(2)/bin
+ $(LN) ../../usr/bin/daq-modules-config $(2)/bin/daq-modules-config
endef
define Package/libdaq/install
@@ -60,8 +63,6 @@ define Package/libdaq/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/daq
$(CP) $(PKG_INSTALL_DIR)/usr/lib/daq/*.so* $(1)/usr/lib/daq/
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/daq-modules-config $(1)/usr/bin/
endef
$(eval $(call BuildPackage,libdaq))