aboutsummaryrefslogtreecommitdiff
path: root/libs/libcanfestival
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2016-11-27 22:16:43 +0100
committerMichael Heimpold <mhei@heimpold.de>2016-11-28 09:10:27 +0100
commitaf00af445e0a9838e37f59b3409f2fe82e7a9e8a (patch)
tree586cb837dd68ef1d067dc899ede5e65a1b957f56 /libs/libcanfestival
parent640d377622f315a60599ec6a8fd33da8de9d045b (diff)
libcanfestival: skip building examples
At the moment, LEDE buildbots are complaining with: -snip- ... libcanfestival/examples/TestMasterSlave/TestMasterSlave.c:50: undefined reference to `MasterMap1' TestMasterSlave.o: In function `InitNodes': ... -snap- Since we are only interessted in the library itself, skip compilation of the example code. This should both fix the build and speedup it a little bit. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'libs/libcanfestival')
-rw-r--r--libs/libcanfestival/Makefile2
-rw-r--r--libs/libcanfestival/patches/003-makefile-skip-examples.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/libs/libcanfestival/Makefile b/libs/libcanfestival/Makefile
index dc11a7174..ee5df9f1a 100644
--- a/libs/libcanfestival/Makefile
+++ b/libs/libcanfestival/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
diff --git a/libs/libcanfestival/patches/003-makefile-skip-examples.patch b/libs/libcanfestival/patches/003-makefile-skip-examples.patch
new file mode 100644
index 000000000..e52fc6ab2
--- /dev/null
+++ b/libs/libcanfestival/patches/003-makefile-skip-examples.patch
@@ -0,0 +1,20 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -21,7 +21,7 @@
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ #
+
+-all: objdictedit canfestival examples
++all: objdictedit canfestival
+
+ examples: canfestival driver
+ $(MAKE) -C examples all
+@@ -44,7 +44,7 @@ driver:
+ install: canfestival driver
+ $(MAKE) -C drivers $@
+ $(MAKE) -C src $@
+- $(MAKE) -C examples $@
++ #$(MAKE) -C examples $@
+ $(MAKE) -C objdictgen $@
+ ldconfig
+