aboutsummaryrefslogtreecommitdiff
path: root/libs/libarchive
diff options
context:
space:
mode:
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-23 15:49:52 +0200
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-23 15:53:12 +0200
commit1dc00a2b0a451909dcf8b97ba192558d88a0e2ab (patch)
treea1d14f32bf180de9490236ec3c57d8404b80cbde /libs/libarchive
parent0bef49ff5a65126b3a0cf79c5b19ddefdb639841 (diff)
libarchive: Reduce dependencies by disabling them using configure args
In order to reduce the dependencies, this patch disables following features: * Extended Attributes * ACL support * bzip2 through bz2lib * lzop through liblzo2 * crypto support from Nettle * xar through libxml2 Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Diffstat (limited to 'libs/libarchive')
1 files changed, 9 insertions, 1 deletions
diff --git a/libs/libarchive/Makefile b/libs/libarchive/Makefile
index b673111bc..1693cd015 100644
--- a/libs/libarchive/Makefile
+++ b/libs/libarchive/Makefile
@@ -30,7 +30,7 @@ endef
define Package/libarchive
$(call Package/libarchive/Default)
- DEPENDS:=+libxml2 +libopenssl +zlib +libacl +libattr +libbz2 +liblzo +libnettle
+ DEPENDS:=+libopenssl +zlib
TITLE:=Multi-format archive and compression library
endef
@@ -38,6 +38,14 @@ define Package/libarchive/description
Multi-format archive and compression library.
endef
+CONFIGURE_ARGS += \
+ --disable-acl \
+ --disable-xattr \
+ --without-bz2lib \
+ --without-lzo2 \
+ --without-nettle \
+ --without-xml2
+
define Build/InstallDev
$(INSTALL_DIR) $(1)
$(CP) $(PKG_INSTALL_DIR)/* $(1)/